summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-22 09:45:21 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-22 10:55:43 +0100
commit54e9d2e4d42c40f3cf0b18eb928d4de4fd6429b0 (patch)
tree23ff094b835dfb8f14a7d4e0df46ad30d462d1f5 /dev-python/boto3
parentdev-python/botocore: Bump to 1.19.58 (diff)
downloadgentoo-54e9d2e4d42c40f3cf0b18eb928d4de4fd6429b0.tar.gz
gentoo-54e9d2e4d42c40f3cf0b18eb928d4de4fd6429b0.tar.bz2
gentoo-54e9d2e4d42c40f3cf0b18eb928d4de4fd6429b0.zip
dev-python/boto3: Bump to 1.16.58
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.16.58.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 784c4f8fca20..b7052162543a 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.16.43.tar.gz 342444 BLAKE2B 1a367fa252eab6738533c7bec2bc370dcc206f2
DIST boto3-1.16.50.tar.gz 342744 BLAKE2B a6581acbdb07f2d8ce21ddf384b471d281d58910366dee0669f0f726118eabd52de8a4fe129915b9044bd484950155c32fa4f4941e1ef6ce55249213ba29f2f3 SHA512 de483be833917a2c478c0fe651ffe4143dc6c742e259711a955be41a8b76197353b295526695ca800bb860b95e0378dc461119bfa163c4be0faa3b6c2ccfc097
DIST boto3-1.16.56.tar.gz 344547 BLAKE2B da32affd031a7efd7f55ec390f657d02caaf37d5c226ed811934e101dee1fcdc6df8b678ddaa181cdec140ad70525ff0a462885eee21f924040b1f2051d0f1f0 SHA512 2f35d4331db005ecb8dca5c780ebb2347242564f541e5b9585f0645e113255aeb8dff2210ecc42a2768f2b58c6731d59d6cb5eb7ac143e7aafd2bf21eae7d7ab
DIST boto3-1.16.57.tar.gz 344712 BLAKE2B 572a70f9afad3502d9f2bbaa5950654e45d40269bbb995e96d94573b423d4e182d314e36de97435c93f9608c780b79e073da79fcd4dd699899a83b60d864907d SHA512 a588ebdd03d189b63999523a2f68c0f1021b82299bf9875f7aebc3120b8db61afd9d784fb65885c87efe9e8ebe416f3c601ddd9615965a61a5910bb1f8e89e9f
+DIST boto3-1.16.58.tar.gz 344789 BLAKE2B dfaac853e0e26b17612dbf20ffa83363c3bfcfcaca4f31b1c6e987c073c291eebe3c692a0f530b0491bc5042b3de627607694bd90df57f4df8503057233dfb14 SHA512 6d1fba2f614398b7b897e422a387553fcd796027f9929f6df5dc862ce06385d2b21e119246ad7e86b71ca050cd3f29a9801101d0cf3bdb8f5fd7772bb6ee9e66
diff --git a/dev-python/boto3/boto3-1.16.58.ebuild b/dev-python/boto3/boto3-1.16.58.ebuild
new file mode 100644
index 000000000000..7be6516ff810
--- /dev/null
+++ b/dev-python/boto3/boto3-1.16.58.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}