summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-16 06:33:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-16 06:33:40 +0200
commit5553d39ed23062cdc5ecedbca8787c2890381cb4 (patch)
treecd72a060db8bfd367b53c726026eb216e5fdd62f /dev-python/boto3
parentdev-python/botocore: Bump to 1.27.10 (diff)
downloadgentoo-5553d39ed23062cdc5ecedbca8787c2890381cb4.tar.gz
gentoo-5553d39ed23062cdc5ecedbca8787c2890381cb4.tar.bz2
gentoo-5553d39ed23062cdc5ecedbca8787c2890381cb4.zip
dev-python/boto3: Bump to 1.24.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.10.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index be152ce9b8d2..bff27b6a4790 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,4 +1,5 @@
DIST boto3-1.23.10.gh.tar.gz 504080 BLAKE2B 1840715ec72b10131a430abdb303adf7619fb4dc542cb22acefffe378c96d094eb7d024c068df1df48882a22fc52e3883791da39d0e4fb34abdddad4d78c0ce8 SHA512 88d0abfc990eba2118698c27fe9f556a2b2ef27d0e287c2b3d65a1d485d4be264a5e9ccc02c017c404941c34efdb5f9d480ceb7c5752f99ebf95d3fab184dded
+DIST boto3-1.24.10.gh.tar.gz 508606 BLAKE2B 5f4a4a8a39fb48d8cb15d3e0aec7304df57ce5a5c40d4dc41f7780645fb7e09fbfafe96588d92ea85af3c6d26d319510b534ee7b8c52f56aa166116edde7fc7d SHA512 98433526006e16af552e22722b5c913eca0d7de63f172312c168ccab7bdc2b587f265a89c2f4d7e948962393907044a0a493e49e627d731d27733e66fcae0407
DIST boto3-1.24.2.gh.tar.gz 505904 BLAKE2B e5fe9aa089caaa91aa41554a07ba97da55b04f5cc77be58df10ad4b6b9d3ab8ce22f988f658cb653d9f3890a307ea895c1cd57c30b6729ba12a1ee61f475ba1d SHA512 23b550194805859e37b8f3a7b75390bba500e7043e32930ab1ac46d2fca672472def9f4821e0deadaba6e6010afa05e4385a0f6fe229798250746b079fa27810
DIST boto3-1.24.3.gh.tar.gz 506694 BLAKE2B 5049ad69810c0fcb4d4133fae8efb7d5f44a5b766c3a53710692136231c2f147b08a6782e51f12ab0e22189cb8bbaf90805ca03d0f6eeffe047678b1b21cf72f SHA512 7652ffbfb41df2dde924e85c251dba84643d67b719ea7dc366dcb0f6988815474b0e2a44dba74ebda5f9b1f5576df715dbd16b70ad4109e846766bf34e9d92d0
DIST boto3-1.24.4.gh.tar.gz 507020 BLAKE2B 2689aa84d0cc5a8c7978d18c480576015bb212a2714eb4edf3f9dd59e0be09da4a866e64fad1f3033cf02b807af7f827cceb56716bec5f04048c2eeb49b12804 SHA512 d23d1d7cb11d45d4419a5c4c1fcadacbfff8e8ebae69c8e522aa00e966048cd341bff8587e18bd0f043f1abd0558522aecede3aa83b84498df95c5a06068f15b
diff --git a/dev-python/boto3/boto3-1.24.10.ebuild b/dev-python/boto3/boto3-1.24.10.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.10.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}