summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-17 09:17:21 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-17 09:33:19 +0100
commit5cc6ed0515b8e1c3f710bb95aa1c3eed38349632 (patch)
treec215e4cd585fa1d14059b51b8259ba3847fbfdf9 /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.9 (diff)
downloadgentoo-5cc6ed0515b8e1c3f710bb95aa1c3eed38349632.tar.gz
gentoo-5cc6ed0515b8e1c3f710bb95aa1c3eed38349632.tar.bz2
gentoo-5cc6ed0515b8e1c3f710bb95aa1c3eed38349632.zip
dev-python/boto3: Bump to 1.17.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.9.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index c153b171734c..28c4153e344c 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -14,3 +14,4 @@ DIST boto3-1.17.5.tar.gz 346437 BLAKE2B 43cec95e82c2f4b78132966aebb3fb1b8e8e0192
DIST boto3-1.17.6.tar.gz 346445 BLAKE2B 778dd820ab134a0c9bc0e67e692e8e1200f84335895a5ed3150eda53ac90dadef09f44c18c2a80858e2c37617c315ff411efec8f1008b8c21179ff519fc4bf9f SHA512 0cca89bd4bfbda7039262ce570c4235bd2ae33e46972026e5f6f66ae42cee9562d23854c3ea23e0fb9b472fc2a28cdabfbb740ae1f0db306c6342cea3c077e82
DIST boto3-1.17.7.tar.gz 346682 BLAKE2B 08c06dda1d59b4f555cad075673917b38cbf9ad8d0037f66027b17076e60b4d5fd32a93e088635320ebc3226a9cd8809c9208ec84f8588c26a77766b21dbee98 SHA512 2ba1817575c4a64c232c84a75a9d3b0db1de8634ded9aa31844930a82ccf4611805c6dd31b2e4d36cc9a2cc1813d233b4d7366305eaf28efd46a3b843d3c2993
DIST boto3-1.17.8.tar.gz 346837 BLAKE2B 44a89727a93320ae8feeef584ed8a04fc5e95598252b3943cfba8b6dad7a6fd3872d5f6f6b7c77063cec0081f49d000adaf26f447386193758902e0a45ff63d6 SHA512 ef5fb47f1023f1c6e968bec9eb6be7f2cf06b5517cf5f9e19656be0cdec3dd75f749decd6fada9f789e378cbef7bb9d71c1bc94aebfa8b84b5efe0647e59250a
+DIST boto3-1.17.9.tar.gz 346868 BLAKE2B 58433cb38615da1137e7ad4abcee2a9e20f8621ef540b0d7830bffaa14dedd65aeb16a52a41466eb9bdbcceea05092f747069e7a1b42c6c5483bed7677ac0925 SHA512 a0603783909dbf16d5f46742760521d25c6e90bff7fa1d763c8800fdbbb2ae444b75e1a74833c012c2ae614ec66f9db80a55197388f9af18e900351ab1d28a8f
diff --git a/dev-python/boto3/boto3-1.17.9.ebuild b/dev-python/boto3/boto3-1.17.9.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}