summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-29 09:37:11 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-29 10:00:15 +0100
commit63ac7d840391e1f9d19956c7db9f58787c2d8132 (patch)
tree44740fea53dd3f703b4bf43febaa5020f32ce196 /dev-python/boto3
parentdev-python/botocore: Bump to 1.19.62 (diff)
downloadgentoo-63ac7d840391e1f9d19956c7db9f58787c2d8132.tar.gz
gentoo-63ac7d840391e1f9d19956c7db9f58787c2d8132.tar.bz2
gentoo-63ac7d840391e1f9d19956c7db9f58787c2d8132.zip
dev-python/boto3: Bump to 1.16.62
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.16.62.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 0a0f999e34b4..ec55bcdecaf5 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.16.50.tar.gz 342744 BLAKE2B a6581acbdb07f2d8ce21ddf384b471d281d5891
DIST boto3-1.16.56.tar.gz 344547 BLAKE2B da32affd031a7efd7f55ec390f657d02caaf37d5c226ed811934e101dee1fcdc6df8b678ddaa181cdec140ad70525ff0a462885eee21f924040b1f2051d0f1f0 SHA512 2f35d4331db005ecb8dca5c780ebb2347242564f541e5b9585f0645e113255aeb8dff2210ecc42a2768f2b58c6731d59d6cb5eb7ac143e7aafd2bf21eae7d7ab
DIST boto3-1.16.60.tar.gz 344983 BLAKE2B c479bc65a04ef01576b046452b125eef931274923dcc3122ca216affd7de55198ace650cf3923fe062ee9a1246d9bd6b2a9e512b88aa91ca5dd8426f3c341958 SHA512 cc7764ace2f94b657de3f6fba977c0b8dcf3e71d159e3ea93fe2d2a6c2e02357655dc08d5ad21e4884173f5a79204c8405d833b4f78063e7f071e7ff8299de7f
DIST boto3-1.16.61.tar.gz 345049 BLAKE2B 542dc15da302d9eeec31d99d2ee0c1229e4155b1f02ffb295819b0365ad9a9f4b87d2adc67e35b760b5a9be27cfb6c6445c5f22472c1a45d8ffca536f2737b51 SHA512 3e27c6b5c638171941b33a6e22b167a6e2bb5609c9e10cf4b7b2991a81ea5a03d3cb911ff1cf53aaf875327463cfb8437f3922c767d51a8386d665d8ec642096
+DIST boto3-1.16.62.tar.gz 345246 BLAKE2B 26b88075e2d5a14b98a3868c4c8f6c7f13d4188c73f5c6884971fb7e3f61ec7f2f371d95f381150b630c94fb2d0d4abc8ba1cf48ecbbce44a23890e15a72ee45 SHA512 1dfa6f45caf57bffe33308bafc68ffa8180d34349a7d84862c6a105139e7ec5134c932fd0050e2ea4375a066724c002c52b6809f0f9fe2a831f48967f86dcc78
diff --git a/dev-python/boto3/boto3-1.16.62.ebuild b/dev-python/boto3/boto3-1.16.62.ebuild
new file mode 100644
index 000000000000..7be6516ff810
--- /dev/null
+++ b/dev-python/boto3/boto3-1.16.62.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}