summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-16 01:17:40 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-16 01:32:26 +0100
commit67123638411d438009b08b720a110d486120074e (patch)
tree35bafa798e6d1c21f0ec708d61187dd29aef6f3f /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.8 (diff)
downloadgentoo-67123638411d438009b08b720a110d486120074e.tar.gz
gentoo-67123638411d438009b08b720a110d486120074e.tar.bz2
gentoo-67123638411d438009b08b720a110d486120074e.zip
dev-python/boto3: Bump to 1.17.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.8.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 91535222551c..c153b171734c 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -13,3 +13,4 @@ DIST boto3-1.17.4.tar.gz 346342 BLAKE2B 3fba8f8b68edb268f20919bb65c5f8715d6c89c5
DIST boto3-1.17.5.tar.gz 346437 BLAKE2B 43cec95e82c2f4b78132966aebb3fb1b8e8e01929731e0a9aace2a281a86fb789ec940a62b13c2c8f82e03d7c2a7c89b3b919aa39be85e6d14e1459782b90ef8 SHA512 bd3dde9acd33371eaee9715c4d5dfa095f6571f728213992455864da15a8f49053991babe4cc57bb808bc7733101b50baeab6ed6a6e58fc04f25a4eee00b774a
DIST boto3-1.17.6.tar.gz 346445 BLAKE2B 778dd820ab134a0c9bc0e67e692e8e1200f84335895a5ed3150eda53ac90dadef09f44c18c2a80858e2c37617c315ff411efec8f1008b8c21179ff519fc4bf9f SHA512 0cca89bd4bfbda7039262ce570c4235bd2ae33e46972026e5f6f66ae42cee9562d23854c3ea23e0fb9b472fc2a28cdabfbb740ae1f0db306c6342cea3c077e82
DIST boto3-1.17.7.tar.gz 346682 BLAKE2B 08c06dda1d59b4f555cad075673917b38cbf9ad8d0037f66027b17076e60b4d5fd32a93e088635320ebc3226a9cd8809c9208ec84f8588c26a77766b21dbee98 SHA512 2ba1817575c4a64c232c84a75a9d3b0db1de8634ded9aa31844930a82ccf4611805c6dd31b2e4d36cc9a2cc1813d233b4d7366305eaf28efd46a3b843d3c2993
+DIST boto3-1.17.8.tar.gz 346837 BLAKE2B 44a89727a93320ae8feeef584ed8a04fc5e95598252b3943cfba8b6dad7a6fd3872d5f6f6b7c77063cec0081f49d000adaf26f447386193758902e0a45ff63d6 SHA512 ef5fb47f1023f1c6e968bec9eb6be7f2cf06b5517cf5f9e19656be0cdec3dd75f749decd6fada9f789e378cbef7bb9d71c1bc94aebfa8b84b5efe0647e59250a
diff --git a/dev-python/boto3/boto3-1.17.8.ebuild b/dev-python/boto3/boto3-1.17.8.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}