summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-05 10:01:16 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-05 10:01:16 +0100
commit6d2f0eaca22a557971debaa62ca36d6f9b831f57 (patch)
tree3c6fd3fe7c98264e94442a2e3859b0080449c3a2 /dev-python/boto3
parentdev-python/botocore: Bump to 1.19.30 (diff)
downloadgentoo-6d2f0eaca22a557971debaa62ca36d6f9b831f57.tar.gz
gentoo-6d2f0eaca22a557971debaa62ca36d6f9b831f57.tar.bz2
gentoo-6d2f0eaca22a557971debaa62ca36d6f9b831f57.zip
dev-python/boto3: Bump to 1.16.30
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.16.30.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 05ae43790beb..abedde06f0b1 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -9,4 +9,5 @@ DIST boto3-1.16.25.tar.gz 340338 BLAKE2B 1ad36d77c3b1e6e67dbd8148b995d4299fceb1f
DIST boto3-1.16.26.tar.gz 340309 BLAKE2B df2c193b5e40f52381a4214fd5c6db9dcb0f32e3bdedf78b1ea16d166b9831c06b871809d1f0673bb3cd2838cb1f722a18a4c25a8c21fa20e5f7c14df9a7efb3 SHA512 1063702783e07a4e5a5ddce3611e57e993c284a09c026dab8af56be7a7a8ac157da2b636b808f58f0aa7940f90a7e36e439b8497713d4f95964dda13684b3795
DIST boto3-1.16.28.tar.gz 340709 BLAKE2B 3c5520531efbb5e20f679f28f4c60964a7be38a0601f73dc0fa5ab3e2cb96939d985c1ebc20869b3fd2f556e9da836fdce4d92377fb9168eccd13cbcffd7c8c6 SHA512 72c10598560ad8d227250274fb296f11e6a1c417f8430221fd8a85e920c8a783be77193dd83ac53dc5000c2ea27c8ff626a5ef3cdee0a467237e732dd6442cdd
DIST boto3-1.16.29.tar.gz 340743 BLAKE2B 1ef74d98aecf8dfd46bc340984d65e5dc2a70f320149b6bab18588a8371d0da6c93102da96f12950d0730c871fb6f13c7441f7ca148f974cb8678bd01b3af24a SHA512 59f8dba245c7525e4ddeec121d85919310e2bd6cf90419c19612434beff66bab4cca22968347512b0f9f2563ff3ee4d85e2d01bf10ce175c3a12a9a09c2e09a6
+DIST boto3-1.16.30.tar.gz 340801 BLAKE2B fcf87b43d2c18ecf1e9d7f0c8c423143e44777a6249a9893d0ebb4016703a9d87a157ed71fca98c8bd73419e6dd2bd2621d42406220e67e6dd462e1088837334 SHA512 66d3e4ae6296b1fbd31187228246c99e472ccfba756d6ca304eca134271d43dd80d1bc35af1fb63336a7c63f2341212329dde307cbbb2dce25e2aa0705c6a436
DIST boto3-1.16.9.tar.gz 337905 BLAKE2B ed01e28fd7e62e5e5028307c93f92004bfbecffa77bc2ba1d6574b92ec2c515d910eb5107ac5ee03e0aca909f97f379aa65b5f839c8067634fa69266c58de33f SHA512 7343b8432788ef981819f91fe2ba27c4ec3947d01ff55914f7c89607250ecf60db2da8d25c8a2c7001ef546a9abed4cb744c5937ca09497aa1a983049648bd5e
diff --git a/dev-python/boto3/boto3-1.16.30.ebuild b/dev-python/boto3/boto3-1.16.30.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.16.30.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}