summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-06 08:41:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-06 09:22:31 +0200
commit814c391c67d4c1ccb92d2ee83308ce57c4facb5b (patch)
tree29d9840832671c468b936272d652eadb8f4a86a2 /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.45 (diff)
downloadgentoo-814c391c67d4c1ccb92d2ee83308ce57c4facb5b.tar.gz
gentoo-814c391c67d4c1ccb92d2ee83308ce57c4facb5b.tar.bz2
gentoo-814c391c67d4c1ccb92d2ee83308ce57c4facb5b.zip
dev-python/boto3: Bump to 1.17.45
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.45.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 6ac2d7f52818..eb92d34dc2ae 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -8,3 +8,4 @@ DIST boto3-1.17.41.tar.gz 355972 BLAKE2B f58dc93b53850781d89db65dcdb17b60141b3db
DIST boto3-1.17.42.tar.gz 357288 BLAKE2B 9a92b8dcee054e408954ea1cf31c776777fcf275ed3ccbccb2dca68acc5e6e6215576dc33bf401b5786a3c6f9995eed16f4be093f7d2bad13f781bf10fc2d13f SHA512 b7a9b06a69eefdc3b25b0bedcf7a4e775cb2099b8106541acf9cea5a95cf6a747f30497bbaacbe66931bb6280047f191cd6129815141ef3bd9a75f5691c04075
DIST boto3-1.17.43.tar.gz 358179 BLAKE2B 7d0a9344642b8c2a4241296327e055abe700c82776e83f12f30ff510ac9364ca6e7fd49f254ce8a3e1ac7123cbb747665dcba774e9befdfd053b3db1f72615bb SHA512 d6271b4563c92097f9c670f4e9c73c01c2a6764d344bed84a4bb08fb7989cd38147890e2c9526cfcbc2e1ae1de9d1e596385c5dc662db7b75c35a69d5ff79831
DIST boto3-1.17.44.tar.gz 358816 BLAKE2B 1739762cf4723d6fde30080d468732dd6fb9bc9e2d66b37621a545262a60cc2783505f39dabad28af34d4f2d69720053a256cb823937a99b699d76513fb9294d SHA512 69e3357f363e08b3135ffdf6aaac6049b0619fafd82049679b238f35013864cdf599452bd94ccd7c27a4da441bc81be79ebebd05b20460c45f5808c3b70cb9ca
+DIST boto3-1.17.45.tar.gz 359297 BLAKE2B 2e0f2b3b13db473f2067d2d662dbe867189f4e82bd9730d1acda8448fe30d85d59a4a5a618e4ac9c3bd29ed3167eb05aee06138027b83497349cef8e1ece8565 SHA512 a686f19e788248a61deeff1c58fa18d3d000b32f3303c177f28db954d1bdec841a042f8310a545dc2214536ba4bcdf59d50173a7ca54e90bef68d61c6276b7f4
diff --git a/dev-python/boto3/boto3-1.17.45.ebuild b/dev-python/boto3/boto3-1.17.45.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.45.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}