summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-09 08:38:42 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-09 10:41:41 +0200
commit8339094935e2ab8a7ee8cc70414c46b8c0cb389f (patch)
tree8fb209043f625e164dd3f25684e6fc191aeff7fb /dev-python/boto3
parentdev-python/botocore: Bump to 1.27.26 (diff)
downloadgentoo-8339094935e2ab8a7ee8cc70414c46b8c0cb389f.tar.gz
gentoo-8339094935e2ab8a7ee8cc70414c46b8c0cb389f.tar.bz2
gentoo-8339094935e2ab8a7ee8cc70414c46b8c0cb389f.zip
dev-python/boto3: Bump to 1.24.26
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.26.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 60b029245c2e..2d6888c0f1c4 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -6,3 +6,4 @@ DIST boto3-1.24.22.gh.tar.gz 513301 BLAKE2B 1b71d128cc8f8224fd1ef521988e6b5e9415
DIST boto3-1.24.23.gh.tar.gz 514077 BLAKE2B ff5b661d477e8163e83cb85045b61fa8057f9cab0b93b2d4575904b17361801e3ffc928ee86624bdf61213a0dc93be91f101e30f418869a1c5dd65e16ff9ed2a SHA512 c127f11e7cd42d0c7f2b802de425d087722ae81fc642fd6867d44cf1b1686ca94b3de76b3034abbd9b85393f8f59d18ea46cd68a57804e658d65e9fba6e6f9a6
DIST boto3-1.24.24.gh.tar.gz 514350 BLAKE2B 6ddb182ef3fa9018d763747bcc3508bbb37a40576ac80f4fbbd25efaa2a96de411a76a2cfafdea7664926c07f7733245b2a6703d8c2d341e43450e7d7eaa4894 SHA512 2465c33529900a7d67f8cc994a0665879d940967279d33be167dcf2eed078575ddea099a40978b291c7a941e8276f3938bd52a002634e73fe64272d8843e47d2
DIST boto3-1.24.25.gh.tar.gz 515150 BLAKE2B 7a6d1bbe4aa327ad9807305b82ae4de5e7035d5ca65203a4f57811c5178e9ea3dd5253a20d566bc7a3e641a8eca709f9fa39f9d53b17a9a5b85ee4a50d090bbb SHA512 13ef720324abbe710f52811490ac7f96ebfe2137ed02fe80bbcefe7514c01316c4338da1690f84b03eb1e5aaa44f74ffa56292f053a04a813d5afb27cb072a32
+DIST boto3-1.24.26.gh.tar.gz 515531 BLAKE2B 34f99c4dd224731e07c2f0b175d6d172661ce454a7af16be6856053af1bfac69b7f56ada5b154fb625fe2ba1fb22fbe34b5150c550890e46a923b48f2466b06b SHA512 a3980ec79abd5e2656d7d02b36dff6b8c2acb67033eff134d96dccbb9d8bbc2d711698b87d08d537256fad7e3b3cd7af008018ef567b12d63ef0fc871a8f3b3e
diff --git a/dev-python/boto3/boto3-1.24.26.ebuild b/dev-python/boto3/boto3-1.24.26.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.26.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}