summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-18 07:59:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-18 08:59:47 +0200
commit862758a652f23e0a50c2bd88b4782a6cd1e6eeb5 (patch)
tree36a9f21c240d1af8a112e31a27455e6774da257a /dev-python/boto3
parentdev-python/botocore: Bump to 1.26.2 (diff)
downloadgentoo-862758a652f23e0a50c2bd88b4782a6cd1e6eeb5.tar.gz
gentoo-862758a652f23e0a50c2bd88b4782a6cd1e6eeb5.tar.bz2
gentoo-862758a652f23e0a50c2bd88b4782a6cd1e6eeb5.zip
dev-python/boto3: Bump to 1.23.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.23.2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index c9faec249bb9..15aa0e3aa3fa 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,3 +1,4 @@
DIST boto3-1.22.9.tar.gz 497262 BLAKE2B c3fad6d556c62403578347600f2781b5fbf34a5ba975b596878f892cd1981bd06e25e50e4c67e5b5b27d6a0fec3aa8af0ea6e30a38277dcf1ae157719d95b3c5 SHA512 f32d6b9b2a8f2d6fcf975446f2c3530a8ba29dc8a3d55ed7b675bc7fb68694c3e6e1f0c54c3f6a715923f9c10268c7db04d897b73add7098f0e43062d2f28775
DIST boto3-1.23.0.tar.gz 499085 BLAKE2B d606370e274564f909be46cfac838212de3213fd8407f1f2ac26afc3287feaa4aec8bf25ac6db4f1058739b2cbefc99c8e16c9dd0c12a5bdeaacf4700e9b0015 SHA512 c44237239cadb98f257796e152b13514839d2003d2a8157bf5f8a41c726401a3e248ff021ccfcd3e6b8099939744fb309c6f1ba342ff066e84632f1ac97dbaf8
DIST boto3-1.23.1.tar.gz 499867 BLAKE2B 1ea53a7bf5f453a202347f29f0278d5397d6d10cfb52253a64a09ccb6ddfe1a95631045ecf7b526016f314c8773db04d25ed8cd2a539ae20776629079c168b61 SHA512 a1cc49cd53444bbda3fe0bbb1ec6e7e445a53d94af1eda0ed2984f7e0ddc4af14eed09b269cb4b4e62a15d647071bd9a9e5182b7049da745c19ba8da74e5c9b8
+DIST boto3-1.23.2.tar.gz 500287 BLAKE2B b997f18cfb2b5c03eab7decd14a60d70546eb60fb2d52f02d94ee478686bd520e4e8111757e9e073f17f7f415d9eb7243fdcd9ac2e0f2b98f6bd6d34473dc794 SHA512 6a774199b719496143af79b1a8a0612441a4f1d9ce426dfc3d495679bb0fda3856b7b0e81e8403d050de52bf8363dec9f0242cca6b32cf39d172d559d6ddf548
diff --git a/dev-python/boto3/boto3-1.23.2.ebuild b/dev-python/boto3/boto3-1.23.2.ebuild
new file mode 100644
index 000000000000..8b87bf9ae488
--- /dev/null
+++ b/dev-python/boto3/boto3-1.23.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}