summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-24 00:33:03 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-24 08:42:55 +0100
commit8629368008e429daef86c9cbcb5bc131c976922b (patch)
treef1c98de7a440620196f491fa576514fcd5e271ed /dev-python/boto3
parentdev-python/botocore: Bump to 1.19.24 (diff)
downloadgentoo-8629368008e429daef86c9cbcb5bc131c976922b.tar.gz
gentoo-8629368008e429daef86c9cbcb5bc131c976922b.tar.bz2
gentoo-8629368008e429daef86c9cbcb5bc131c976922b.zip
dev-python/boto3: Bump to 1.16.24
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.16.24.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index b77e066f9672..c2b1649a9cbf 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,4 +4,5 @@ DIST boto3-1.16.20.tar.gz 339432 BLAKE2B fefe33be5baca95880a52856a6d6fb166895951
DIST boto3-1.16.21.tar.gz 339637 BLAKE2B 122025941b38dd94ccea22a5561ccac29f3033320da4e3f332a1200c84215bef1a320dc36ce59733265816d867c409449a32830df4f20fa08f943ca754fb9257 SHA512 b811e153b9c356e9e414e8a82076000d885e29778273d9e839d73e2b35405d23ae8236bb57c657c0f2ee6def48636bf024548cdc0f6e5e642c7b97d97b76307a
DIST boto3-1.16.22.tar.gz 339781 BLAKE2B d6703055d57f9d3486218efc3014439a1ca1335d28281793ddcf2c37dd42c1557e85503841e0d7306168d0eb546dbfc16fabeb53a7a00ee32b3b10e74cbfff94 SHA512 dd0df65efea8dc2138b1bfa3a1eb4e40c8e3408f34a36b38cd51346debb01a3e5179b841adbef6cf6fe1535adee9f09d19ff40ae284cfd3c2fabb42a4113f5a6
DIST boto3-1.16.23.tar.gz 339889 BLAKE2B 0a41c084beba187a89ddf8a743c6dc4f3663aebae035468a76967e4b732abdad496bb2f0a516b5af76affa18f99d4c1a3405d0e152fb41fb1fae22a6728542e6 SHA512 942b0a540cdd6ed744bc1b4285ca8d9e3121193a59717fa247431d232f25cf042625abf82709cecef20611feb68735415be2e3187ebd4e6a1efd7488c0db14ff
+DIST boto3-1.16.24.tar.gz 340133 BLAKE2B c1d195d5c6859686b2cbc9cfd772e43b6a052b138d792b896f0fea1b25eb1667d26f09369f6fcb2bfddaaaf8f994f14d2a6e6456aa098af5dbb6ddd8df503118 SHA512 55582c76ffd1d6f3d021c7ab89b6a93ea3bf3597312957497de4c8a226657414271385224e2808aecaa90b0e48f21b7fb8a62462df1cf26f142a7ecd5064f55c
DIST boto3-1.16.9.tar.gz 337905 BLAKE2B ed01e28fd7e62e5e5028307c93f92004bfbecffa77bc2ba1d6574b92ec2c515d910eb5107ac5ee03e0aca909f97f379aa65b5f839c8067634fa69266c58de33f SHA512 7343b8432788ef981819f91fe2ba27c4ec3947d01ff55914f7c89607250ecf60db2da8d25c8a2c7001ef546a9abed4cb744c5937ca09497aa1a983049648bd5e
diff --git a/dev-python/boto3/boto3-1.16.24.ebuild b/dev-python/boto3/boto3-1.16.24.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.16.24.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}