summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-07 09:32:38 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-07 10:16:02 +0100
commit9dc5dced19113acd8105eb287cdb33990d097504 (patch)
tree01ecd9eb9748242a725ff0b446fc39be4c3e4c65 /dev-python/boto3
parentdev-python/botocore: Bump to 1.19.50 (diff)
downloadgentoo-9dc5dced19113acd8105eb287cdb33990d097504.tar.gz
gentoo-9dc5dced19113acd8105eb287cdb33990d097504.tar.bz2
gentoo-9dc5dced19113acd8105eb287cdb33990d097504.zip
dev-python/boto3: Bump to 1.16.50
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.16.50.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index f4df9bcc5218..06587b9f54fe 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -11,3 +11,4 @@ DIST boto3-1.16.46.tar.gz 342528 BLAKE2B 7c68c2ff006f0a8120eb049ad7dfa765e98b733
DIST boto3-1.16.47.tar.gz 342541 BLAKE2B 956c76bc6f5f07125862ab7614da9d9d6eee1af9d0e3d39ddaeb4f130bb455a05f472a19b578ceae17211cd9e32492048af8b391bd42bc3ee8e26c947d95f08c SHA512 5a4e3d8ee6437254e8a560262531cf7a7055d5d06b530cac2d5940b39cbb3de3cae18aea4d05dec0a304ede76ebef5ed83d1cc3f1200fabfe135afc484aba5df
DIST boto3-1.16.48.tar.gz 342685 BLAKE2B d0137aa8cb9d1951ea1aed8b3457d73fc314e9035c5ff28006579067ac421d3538602861e9cf2ca3f47898da9038c898a9a690487a17772439dcee77c2e0f5f5 SHA512 67f7b7bf725a47d12c47bc604fe82ad8a5f9aebe18a2185140d9c0fe6f78ab45e468de9823910976a073b87adeffb399a8482dac2d61e52c5060a6023113e8e4
DIST boto3-1.16.49.tar.gz 342687 BLAKE2B 1af59bddd9c46a6823a22d2238151cc77cfc8954d4e9e724ba8ed7d3d72f3e5635ae66b0f95bd6764aa7c1a6fd4ce21f83961c97324aea28e0768ed0ba97bbf5 SHA512 e637542710d3b479fb042ce79116fb0a44eece139bdf160cb45f3aa3b8375f10001b96e293440acf0b736c9362e4cb5c87adf632ac5497e1be14879ec7dc2098
+DIST boto3-1.16.50.tar.gz 342744 BLAKE2B a6581acbdb07f2d8ce21ddf384b471d281d58910366dee0669f0f726118eabd52de8a4fe129915b9044bd484950155c32fa4f4941e1ef6ce55249213ba29f2f3 SHA512 de483be833917a2c478c0fe651ffe4143dc6c742e259711a955be41a8b76197353b295526695ca800bb860b95e0378dc461119bfa163c4be0faa3b6c2ccfc097
diff --git a/dev-python/boto3/boto3-1.16.50.ebuild b/dev-python/boto3/boto3-1.16.50.ebuild
new file mode 100644
index 000000000000..7be6516ff810
--- /dev/null
+++ b/dev-python/boto3/boto3-1.16.50.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}