summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-20 21:53:37 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-20 22:38:12 +0100
commita28ba6ac31c4f05fb6194968605fd8dcb6f57cd9 (patch)
treeb077c3cd08f6b5268edd366720baad982559ccb2 /dev-python/boto3
parentdev-python/botocore: Bump to 1.29.54 (diff)
downloadgentoo-a28ba6ac31c4f05fb6194968605fd8dcb6f57cd9.tar.gz
gentoo-a28ba6ac31c4f05fb6194968605fd8dcb6f57cd9.tar.bz2
gentoo-a28ba6ac31c4f05fb6194968605fd8dcb6f57cd9.zip
dev-python/boto3: Bump to 1.26.54
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.54.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 3e5153b2a37f..70a0a16d34ca 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.26.45.gh.tar.gz 587548 BLAKE2B fca56cad5fa8bf3bfa34f76aa7014d6ee112
DIST boto3-1.26.50.gh.tar.gz 589841 BLAKE2B 98808cc2811f6371152b75424abe7da24230beb9caa4fcb62c273c232998fa1bbd4195d47e173c181f6b77cd95c6d90e21dc6126d65a0ce5453244cc03a5a12f SHA512 d4a8fd68c7fa099009e491f697ce3089a7f9d54433d25aa76d2733facde82f62f3955efc8ea5156dabce9502a2912847d45f7e1ab5dc71c1db26ca5d2b4ae220
DIST boto3-1.26.52.gh.tar.gz 590511 BLAKE2B be56b8dd5cb919e042860ab5d80727edb9e4baa50def10e150d8472808614c9b6665e86afd5481476ea37073aaf9f444bd19e107ddb6d3675b1bd0220d451866 SHA512 6e793e19f3632137db8d40889462f793f7c4f54bd41a1e50dc892abd1539a512c19efc86fa0b7364c646f08b563919c7673c6cdf1f5279f330f556ba347c1091
DIST boto3-1.26.53.gh.tar.gz 592023 BLAKE2B 07f09144913b7506dcb790e9a72adacecafdfb80fd22805c0cb4c91d07f147bd76b29a6008b12402449469334e059ab3fd7dff189f6122714077ea6d153999f5 SHA512 c555d769e89234670db1b87e0b5ff90c1b18315c6083e3ed286ce016a756424ef84a928103fa85d36d294b6f44854799f52a12f6633456e79e409547b37952cf
+DIST boto3-1.26.54.gh.tar.gz 592401 BLAKE2B 7fd5bb10cda2b27fc43a7efa65c4651d95c8ddb7c94b424847f21010f9d748398a9efc47118ed7d2d90369664dddd4903fb8c4e7bc3ba3f70643a565b426023f SHA512 86d315eba84d783d327d19b41a593f193d9b356a205f29a1589e43e43519aa6eedefc26e7b23234dade6ab0bbb309d8039b011d0ba766757be8eb7a57c22f49b
diff --git a/dev-python/boto3/boto3-1.26.54.ebuild b/dev-python/boto3/boto3-1.26.54.ebuild
new file mode 100644
index 000000000000..9523f65d5fb9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.54.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}