summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-02 18:03:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-02 18:05:21 +0200
commita53e818cb819ba784fe29d46b7a94427cd301cf3 (patch)
tree8b6a95fa27b61097aaa74a5b2bf0afe7ca6dfbfd /dev-python/boto3
parentapp-admin/awscli: Remove old (diff)
downloadgentoo-a53e818cb819ba784fe29d46b7a94427cd301cf3.tar.gz
gentoo-a53e818cb819ba784fe29d46b7a94427cd301cf3.tar.bz2
gentoo-a53e818cb819ba784fe29d46b7a94427cd301cf3.zip
dev-python/boto3: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest3
-rw-r--r--dev-python/boto3/boto3-1.17.102.ebuild56
-rw-r--r--dev-python/boto3/boto3-1.17.103.ebuild56
-rw-r--r--dev-python/boto3/boto3-1.17.78.ebuild56
4 files changed, 0 insertions, 171 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 6f70bd076c09..a4fef5653513 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,5 +1,2 @@
-DIST boto3-1.17.102.tar.gz 386456 BLAKE2B 25b18f086f8881a237a953c85cecc403fdd1b047f990ae289c16695ca1c1faf50da3cd7363e72d1655d7a887c8f5c0729bb25121fa0066db5d393f5b6cd3d4a6 SHA512 42cbd01626bd11f774466dc718086648eb7a4b73a50226a04485e934010271b0f20c030c300ada074fb0b3bf3eac8f6fa113dee86d0f1cf3f12f12230778c2e5
-DIST boto3-1.17.103.tar.gz 387576 BLAKE2B fe3b6f1e30f00bc47e9361a695cc36622aa05d29abedd192d1bfe730f1c7d18a7337a5f24294fad8a74a293838c9e7315ff421231ecd1921914c21f9bc76dba6 SHA512 2bbe10741bd80cd7fe1cf16d6125a131d2885c66d237eca270e7bb8d459c5907c5a5e4f5ac266f36052fe8f12b9126fb7915c18e5d8adee594bc0245ba1cb5b4
DIST boto3-1.17.104.tar.gz 387800 BLAKE2B 928824ab0a0c091fec430c5d86b0c5663f2a98042a76311588463f36f48a6bd9641fd25e07b63ad50afcb3ea9bfea0b5f3304e3c2689a2187198aac04549346c SHA512 477033e623476fa1e2e49cdb788f204ac49230088788cbae3f079de4561e7bbe56bb3b170480592a0ce056fcd2ea0cb3f14b4f5091279f46346465853a191829
-DIST boto3-1.17.78.tar.gz 374487 BLAKE2B 8a83cb32db8336351454251a3cf78efad6197885a66c10a4e3f9e13770d92d7cd9e9b51bfc7c4bfdb2f5183c5246872d7f3075d55b5129606ad9d977ecbf9891 SHA512 8ab9f13360f63342219d7b0278e2ca5613f8d051d006ef26da14307e83fcaaf1a546c566cb4b8ba012fa5e8e6b5e409722228da0989e56f50e40df4a733602de
DIST boto3-1.17.97.tar.gz 383223 BLAKE2B 1a1b4e9f2c51d830762f27cf3e30038efb88322e300ac304d1cb88d5b7efc6af35ad9810cea7292c9807dcdfedb11ba039ee6d5dbb9162f2a1c6d6936ef75bcc SHA512 e74a59763cc9b8a51fd09121a790d29a7291d9380d4451c2e6af90902f18415a3780eeea7f7d63e052b295792b92c3cdd3b8597f7013241ebbbdb7e418cf73ce
diff --git a/dev-python/boto3/boto3-1.17.102.ebuild b/dev-python/boto3/boto3-1.17.102.ebuild
deleted file mode 100644
index 75afb4bcf865..000000000000
--- a/dev-python/boto3/boto3-1.17.102.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="The AWS SDK for Python"
-HOMEPAGE="https://github.com/boto/boto3"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/boto/boto3"
- inherit git-r3
- BOTOCORE_PV=${PV}
-else
- SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
- # botocore is x.(y+3).z
- BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
-fi
-
-RDEPEND="
- >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
- >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
- >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source \
- 'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests nose
-
-python_prepare_all() {
- # don't lock versions to narrow ranges
- sed -e '/botocore/ d' \
- -e '/jmespath/ d' \
- -e '/s3transfer/ d' \
- -i setup.py || die
-
- # prevent an infinite loop
- rm tests/functional/docs/test_smoke.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
-}
diff --git a/dev-python/boto3/boto3-1.17.103.ebuild b/dev-python/boto3/boto3-1.17.103.ebuild
deleted file mode 100644
index 75afb4bcf865..000000000000
--- a/dev-python/boto3/boto3-1.17.103.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="The AWS SDK for Python"
-HOMEPAGE="https://github.com/boto/boto3"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/boto/boto3"
- inherit git-r3
- BOTOCORE_PV=${PV}
-else
- SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
- # botocore is x.(y+3).z
- BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
-fi
-
-RDEPEND="
- >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
- >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
- >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source \
- 'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests nose
-
-python_prepare_all() {
- # don't lock versions to narrow ranges
- sed -e '/botocore/ d' \
- -e '/jmespath/ d' \
- -e '/s3transfer/ d' \
- -i setup.py || die
-
- # prevent an infinite loop
- rm tests/functional/docs/test_smoke.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
-}
diff --git a/dev-python/boto3/boto3-1.17.78.ebuild b/dev-python/boto3/boto3-1.17.78.ebuild
deleted file mode 100644
index 95cca01df831..000000000000
--- a/dev-python/boto3/boto3-1.17.78.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-inherit distutils-r1
-
-DESCRIPTION="The AWS SDK for Python"
-HOMEPAGE="https://github.com/boto/boto3"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/boto/boto3"
- inherit git-r3
- BOTOCORE_PV=${PV}
-else
- SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-
- # botocore is x.(y+3).z
- BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
-fi
-
-RDEPEND="
- >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
- >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
- >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source \
- 'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests nose
-
-python_prepare_all() {
- # don't lock versions to narrow ranges
- sed -e '/botocore/ d' \
- -e '/jmespath/ d' \
- -e '/s3transfer/ d' \
- -i setup.py || die
-
- # prevent an infinite loop
- rm tests/functional/docs/test_smoke.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
-}