summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-15 23:05:43 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-15 23:32:35 +0200
commitb1a320359622cd1252638e13afd3f0a5dd47fde6 (patch)
tree5f8b91ad07e0b9d720f2187153bdaf68708cd950 /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.95 (diff)
downloadgentoo-b1a320359622cd1252638e13afd3f0a5dd47fde6.tar.gz
gentoo-b1a320359622cd1252638e13afd3f0a5dd47fde6.tar.bz2
gentoo-b1a320359622cd1252638e13afd3f0a5dd47fde6.zip
dev-python/boto3: Bump to 1.17.95
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.95.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 3167b86fdba4..6d0e23491359 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -16,3 +16,4 @@ DIST boto3-1.17.91.tar.gz 380247 BLAKE2B 8017241fce7337ed88f8da35ad914081d7b4a83
DIST boto3-1.17.92.tar.gz 381619 BLAKE2B ea7f1d7fbc1481d22f5e5bce9d051e9d825de215fd9efc9396c9d11723eac70e422b68d9f72a429ddd0bfe9976ad0e6e3c7e7bff74af388996c3e48ac6f383fc SHA512 a96d57eb19e794b4b7a1d4b1ee142f601ca5a10ba7c20500dd3e570131904874fe470cb1ef7146f7eb4ba189a91f9b42dd58acb0c8d54216352c03ae173f8092
DIST boto3-1.17.93.tar.gz 382205 BLAKE2B c665f3a98ffffd3a146914e5c061ec222def64ffffcf2bfcf1fabd86ba5be89d61fe4201b81134fd415b80710ed7d4261ed26eb71fec9c64525f4c2f3ff88533 SHA512 bb1f3264cfa4717f32343553f5af1d35dc7bab813d968775456239a758111cbc7eb6514df42cc3675f1d693f5bae33c048fcdae98c348d3aa54cbb6e98d88f70
DIST boto3-1.17.94.tar.gz 382448 BLAKE2B 84ea4989b47ff4b1adbcb1118bf1a18996d98d954c195671483ac2ada94afd1fbda151afb6dd1be556c5a63535ebf9747c7f9eac99d55ee6cdd64dd163941572 SHA512 a157df1cef3d7d99f319bdce20ff4128cd171cb9ce5b3cd7e286711cb0b3939efafbd4f8b1370fb131af60296d703c1244d4232cedd28c3615d1437c98ba4445
+DIST boto3-1.17.95.tar.gz 383063 BLAKE2B 9d715ce7cf51daa806c0ed6044eca32c51dddc9114899e890e9745db51d574fea02515364cbab3fd82b9960dcc658c02bab89564c98ede13487ead75280c01a5 SHA512 63c78ea41bf79af23159aa8a97bf82ecd6c5b5075c1d077777679cc7ca17de4e91eb9abd19c152e5eeee2d5af47739ba0df3dbca6012c3836b577bc52e52eff4
diff --git a/dev-python/boto3/boto3-1.17.95.ebuild b/dev-python/boto3/boto3-1.17.95.ebuild
new file mode 100644
index 000000000000..666cbfa63e3f
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.95.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}