summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-05 11:01:15 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-05 11:13:57 +0100
commitba4d5936c505cd3d2c873bad705e46ef35d63bd2 (patch)
tree4b09d40e516014b2c40a67fbb04405629d94b961 /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.21 (diff)
downloadgentoo-ba4d5936c505cd3d2c873bad705e46ef35d63bd2.tar.gz
gentoo-ba4d5936c505cd3d2c873bad705e46ef35d63bd2.tar.bz2
gentoo-ba4d5936c505cd3d2c873bad705e46ef35d63bd2.zip
dev-python/boto3: Bump to 1.17.21
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.21.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 0623e42603d9..6ba86a7c8e55 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,4 +4,5 @@ DIST boto3-1.17.17.tar.gz 347835 BLAKE2B 7861befb9275b0cf36235749369f65b69845ef7
DIST boto3-1.17.18.tar.gz 347971 BLAKE2B 1390758e578763d0e8faba73e44e769224f6b3ff54e88798cd2d3a79c7d0fe5c3ef58a08e6a4aec70a7c3a64bbcbac22cd8471679951794fc1c0e48623f31008 SHA512 372baa35ddb770d65cd680544c9dd504a1e19b1052355b729f5b3ae8ef480ad4e250bef305671b1ec9741d953e813209398e8afe1bd396cc1e9c79221e34c629
DIST boto3-1.17.19.tar.gz 348163 BLAKE2B 47b3f24dd7af7362fb37fb66bb333ac7a607b3d55790e47e3987d88f1ae09fe0a5bcafbbbe6245ecda378a8c56f6cfaa2a86c0b6e0dece58b0b6d2c819646a8c SHA512 ddfccb03335b3389a820a37e2e3ea40414291243291887be6dfd4243e43d918882e7386373578cf6474c5b8c5f592a15e650528b5cf61cb3b989522d4bff7ec1
DIST boto3-1.17.20.tar.gz 348258 BLAKE2B b26a72e3861c8e45a11f4d8da3733cbdefe5e2b4a9328feac2e87a03c92e32efa0f896a60cc1a7e286ad3c93bfc07c1fd92612fed716607f7a408a837ec5954a SHA512 430d796ca12cf6497e70afcde7be5ab77910728bc0cc6cce74ceefc232d93e592d71864c33f403f75a8fb1bf67e7da9435e0f563d8d83b75d315c6ed50f779f1
+DIST boto3-1.17.21.tar.gz 348371 BLAKE2B 97799d4013e8ace6ebdfbb471c51743112e0d103fa1e13b947989c8da5b6517a2a6c088807519c735f5eb80ea1cedef3aae7aea5b2bd7b337af0ddc6744d91d9 SHA512 092e84c0e15a686634ae247295b5e525da605c9845950094525746df07e59082f36e90be66cb7726f6bc0ce4ac918aeb7e8f8efced98c1a002b8775d5ea68a04
DIST boto3-1.17.7.tar.gz 346682 BLAKE2B 08c06dda1d59b4f555cad075673917b38cbf9ad8d0037f66027b17076e60b4d5fd32a93e088635320ebc3226a9cd8809c9208ec84f8588c26a77766b21dbee98 SHA512 2ba1817575c4a64c232c84a75a9d3b0db1de8634ded9aa31844930a82ccf4611805c6dd31b2e4d36cc9a2cc1813d233b4d7366305eaf28efd46a3b843d3c2993
diff --git a/dev-python/boto3/boto3-1.17.21.ebuild b/dev-python/boto3/boto3-1.17.21.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.21.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}