summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-13 09:35:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-13 11:05:43 +0200
commitba9cd7ad0b003aa939d1e7ecf3d6ced6fd9d0a56 (patch)
tree7f1e093a18ce4c7d720453144a94ae85bd96430e /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.50 (diff)
downloadgentoo-ba9cd7ad0b003aa939d1e7ecf3d6ced6fd9d0a56.tar.gz
gentoo-ba9cd7ad0b003aa939d1e7ecf3d6ced6fd9d0a56.tar.bz2
gentoo-ba9cd7ad0b003aa939d1e7ecf3d6ced6fd9d0a56.zip
dev-python/boto3: Bump to 1.17.50
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.50.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index f12bd907d5e9..8f3c5d214cb8 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,3 +1,4 @@
DIST boto3-1.17.33.tar.gz 352659 BLAKE2B b78e3ce86b32d23ade26d93d0c3ba86020a94becb42a866be6ee02f268819eb78fde398b4bd3125c5be6b493b28434c448411b9bd83eb631a3687019aa384ae0 SHA512 452cb1d165afe03a7603999033348524212d62742a026bc51677f5b64e9de98be2920c89f7aaf5999dd676c0c9ff098af055edc01edd97bad239815263ffbd38
DIST boto3-1.17.44.tar.gz 358816 BLAKE2B 1739762cf4723d6fde30080d468732dd6fb9bc9e2d66b37621a545262a60cc2783505f39dabad28af34d4f2d69720053a256cb823937a99b699d76513fb9294d SHA512 69e3357f363e08b3135ffdf6aaac6049b0619fafd82049679b238f35013864cdf599452bd94ccd7c27a4da441bc81be79ebebd05b20460c45f5808c3b70cb9ca
DIST boto3-1.17.49.tar.gz 360898 BLAKE2B 6fa6fddf1f5df4d28ed2163feef1f3e3349c9096a9aaa2d07a9ed0c82c893a40227b8f714fec95bf271622e3243faf6b2f6d087bb0b09094ad99e1ae764c7795 SHA512 ed49d19cc9076828c01665af616d12e7b8466aaccaafb263ee845bec6dc3e49c79a85347c68230358658b39b8ff656b674f8812c69b820bb455b584152ce39d6
+DIST boto3-1.17.50.tar.gz 361144 BLAKE2B 2c8549cfb2017e0a2aa6a164c286685e71abe8c7a773baeabc50603ab243b993db88f85a1e5d7d0d9e1c9541df8ed3bab70077d2890f73c1ef760f2bcae85894 SHA512 1cb9405de5b960f55f01ec5d13f3385e8ea99354fc465ae342d3b072ebe179be800ce3100304068731a0a9912b7ea09099c94fe9cf736d0e8a5c88c28d4c9b93
diff --git a/dev-python/boto3/boto3-1.17.50.ebuild b/dev-python/boto3/boto3-1.17.50.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.50.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}