summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-15 22:04:23 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-15 22:29:39 +0100
commitc0d8b8d07f02e0708877325d78ed1302760c5ec1 (patch)
tree052c0524d4111a6f39562a8e785b8edad7bcb5eb /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.28 (diff)
downloadgentoo-c0d8b8d07f02e0708877325d78ed1302760c5ec1.tar.gz
gentoo-c0d8b8d07f02e0708877325d78ed1302760c5ec1.tar.bz2
gentoo-c0d8b8d07f02e0708877325d78ed1302760c5ec1.zip
dev-python/boto3: Bump to 1.17.28
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.28.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 3ca4647e2d87..ddc6da7ea77d 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -11,4 +11,5 @@ DIST boto3-1.17.24.tar.gz 349323 BLAKE2B 41a15fb92218d9aa936300054805b4cda52f373
DIST boto3-1.17.25.tar.gz 349475 BLAKE2B 272c5bebed211d015638a652109f2b56475e0d682ff585915061a495ce26ca6c12a5e844f9d4b73fca105c2f40e3fe7c1aa5bee045af284f45e74899cde3fde2 SHA512 d24c118a4af747360f226c9c6e98e26ad3dacf34f13dadb084fef4e7404d1141c66cf5d7074eeea2c792b134e7b83174bc0be0c387c478fd61de646118b41b9e
DIST boto3-1.17.26.tar.gz 349529 BLAKE2B 8510b229aea7b725c6286772dff6d54a9df684eac7e455929c059fd02919238335c88af5c655e89bfb5821ac4b70415c8dbd2c549563d008823104d6d54088be SHA512 5ceb9dc557796471f4d582bdf47614a078285a83f9463acb92e5e59e9f82dbca379bf02c2288cf38cb5741f7860d6c8b23872305209d8a4ece697943cd06932d
DIST boto3-1.17.27.tar.gz 349887 BLAKE2B 1fde4af489c98b8c4f77660ad278abf6641f70da3a0f84ff33d29d082cd283cd8a9faa17a3d9675ca26453f8928c57bb2e3966c607ab677ed814e544c6c928bb SHA512 9c3e45d17a179edf6ff75c9392a3e16323029e4bcefec757a6dd94ccfad5afe718bf91ca6a72ea59fa2791d5a87e9c4b84d147d35b7f584d2df0f73a623c13fb
+DIST boto3-1.17.28.tar.gz 350316 BLAKE2B a6fab50a064fd81337c013bb2516ba2baaa520aa8e7f08418ddaf9b6f0d99a1c8b8eb29b8fee6ab48620430153a0caf4bd296448e1de35a26a972d2e4bbf6df8 SHA512 c26800e18bb254707f0c7e7005b22b1270eae8bf0b8c13f6bcbbe46105ff7439b36c9c80863aefd1037df314abc687bf9b00045d12fb0d3b7337b02605810876
DIST boto3-1.17.7.tar.gz 346682 BLAKE2B 08c06dda1d59b4f555cad075673917b38cbf9ad8d0037f66027b17076e60b4d5fd32a93e088635320ebc3226a9cd8809c9208ec84f8588c26a77766b21dbee98 SHA512 2ba1817575c4a64c232c84a75a9d3b0db1de8634ded9aa31844930a82ccf4611805c6dd31b2e4d36cc9a2cc1813d233b4d7366305eaf28efd46a3b843d3c2993
diff --git a/dev-python/boto3/boto3-1.17.28.ebuild b/dev-python/boto3/boto3-1.17.28.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.28.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}