summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-22 21:59:12 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-22 22:33:20 +0100
commitc1e6790cc597bdbf0496168c462ad908809ff4ba (patch)
tree022b1ec761eaee2ddca603a3b13af04b046a3006 /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.34 (diff)
downloadgentoo-c1e6790cc597bdbf0496168c462ad908809ff4ba.tar.gz
gentoo-c1e6790cc597bdbf0496168c462ad908809ff4ba.tar.bz2
gentoo-c1e6790cc597bdbf0496168c462ad908809ff4ba.zip
dev-python/boto3: Bump to 1.17.34
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.34.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 3e66820654ca..985cffa4d3e3 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -17,4 +17,5 @@ DIST boto3-1.17.30.tar.gz 351634 BLAKE2B e6ad4b4e09ae45684ccd799da45dcf7844149b3
DIST boto3-1.17.31.tar.gz 352268 BLAKE2B eefb7bcc3c6809fc03de2f175d5c3cfa750bc8650d56d5ee18608077a88a1c09ea79c2de1ce67f7d48129d5c948a7e5e30ab261c55a381ccf5c030dc42ff0ee0 SHA512 2d603a307575ff04877105ac98068d96b676faaa89b73ef470d9341951d5fcc148a57c7e80867d93bf257854ec700f61e48575ceebe19591091bbf2a68701138
DIST boto3-1.17.32.tar.gz 352337 BLAKE2B 0d453ecd51d17291f10d2ffa4ae7b1036dced70a5ca0eafdc5f3073829942ecde57fe20f4d0139bfb2f75bdc47a000624281258ff621b98683ea41eae1a4bc71 SHA512 1bf61e3fcd2d650a534de5e7ed471bbdfeb2be6771f1dbde057ea2e3f3b6a29d6022011b5df90bae5c7ff231aec63ec49501cc3bd42421ec510d73e712060aad
DIST boto3-1.17.33.tar.gz 352659 BLAKE2B b78e3ce86b32d23ade26d93d0c3ba86020a94becb42a866be6ee02f268819eb78fde398b4bd3125c5be6b493b28434c448411b9bd83eb631a3687019aa384ae0 SHA512 452cb1d165afe03a7603999033348524212d62742a026bc51677f5b64e9de98be2920c89f7aaf5999dd676c0c9ff098af055edc01edd97bad239815263ffbd38
+DIST boto3-1.17.34.tar.gz 353010 BLAKE2B a50c6a7d5fa6cf0336fe69d5a78d3dd5b651f6b475ec34bdb3242a3efc0614d567e6dbed1029f7b0483c9b699b30c9c42a676b23671677f1ee89ecbbf06e10f8 SHA512 f1b79b1b626aaa25631f3d99f44a15b2862face3aedff273910f43d44c04bd4211aff240d8f3231280170c5403b75e0058f4a466bdc9d9fb8ce044f32eb998ab
DIST boto3-1.17.7.tar.gz 346682 BLAKE2B 08c06dda1d59b4f555cad075673917b38cbf9ad8d0037f66027b17076e60b4d5fd32a93e088635320ebc3226a9cd8809c9208ec84f8588c26a77766b21dbee98 SHA512 2ba1817575c4a64c232c84a75a9d3b0db1de8634ded9aa31844930a82ccf4611805c6dd31b2e4d36cc9a2cc1813d233b4d7366305eaf28efd46a3b843d3c2993
diff --git a/dev-python/boto3/boto3-1.17.34.ebuild b/dev-python/boto3/boto3-1.17.34.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.34.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}