summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-10 09:16:07 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-10 10:25:00 +0200
commitc65ccd8c9993c1ea69dfde67692a598656e5b71f (patch)
tree934b53470c79d023b565aed3fdf93f2d264c2c7e /dev-python/boto3
parentdev-python/botocore: Bump to 1.27.6 (diff)
downloadgentoo-c65ccd8c9993c1ea69dfde67692a598656e5b71f.tar.gz
gentoo-c65ccd8c9993c1ea69dfde67692a598656e5b71f.tar.bz2
gentoo-c65ccd8c9993c1ea69dfde67692a598656e5b71f.zip
dev-python/boto3: Bump to 1.24.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.6.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 926562a64f7b..820c1eb62ff6 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.24.2.gh.tar.gz 505904 BLAKE2B e5fe9aa089caaa91aa41554a07ba97da55b04
DIST boto3-1.24.3.gh.tar.gz 506694 BLAKE2B 5049ad69810c0fcb4d4133fae8efb7d5f44a5b766c3a53710692136231c2f147b08a6782e51f12ab0e22189cb8bbaf90805ca03d0f6eeffe047678b1b21cf72f SHA512 7652ffbfb41df2dde924e85c251dba84643d67b719ea7dc366dcb0f6988815474b0e2a44dba74ebda5f9b1f5576df715dbd16b70ad4109e846766bf34e9d92d0
DIST boto3-1.24.4.gh.tar.gz 507020 BLAKE2B 2689aa84d0cc5a8c7978d18c480576015bb212a2714eb4edf3f9dd59e0be09da4a866e64fad1f3033cf02b807af7f827cceb56716bec5f04048c2eeb49b12804 SHA512 d23d1d7cb11d45d4419a5c4c1fcadacbfff8e8ebae69c8e522aa00e966048cd341bff8587e18bd0f043f1abd0558522aecede3aa83b84498df95c5a06068f15b
DIST boto3-1.24.5.gh.tar.gz 508100 BLAKE2B 5ad9e6325a507ea94738eebee58200b4c4e967db5afb5a3076ad55b64df8637f961074377375d9bf4df233c1d53444738e82a868515d04dbd9632dad0889e2c0 SHA512 9387c70c54e05b1007135a896e69934d128a31735cdf0b61ccadd9412c7be5d53259c60a2b4410157037f9a95afaf8ef4f4a97d35e290ff12b7deb125a73d903
+DIST boto3-1.24.6.gh.tar.gz 508258 BLAKE2B 705b01006dfa63e386b39a0c4e791e0d9f2e4c5ae72bda3245843ba802556b1328214f80df788497d8b646882af816cfdba6d2769fe5bef82cbaf629fe9fcac6 SHA512 198df4e2f1e5f42bf0faa8baaea0bbc3d88fffda435afc3eccfdcc56940773dcdf43e8cb533a48265907bd118d8e969c7f9b37affb6508a8147ecee486017d92
diff --git a/dev-python/boto3/boto3-1.24.6.ebuild b/dev-python/boto3/boto3-1.24.6.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.6.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}