summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-22 14:18:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-22 14:18:40 +0200
commitc7e09f25ee859a2bb5864325f2150f29987c5e9e (patch)
treee4371b096308e88ecaad20706894b7b8589ffe26 /dev-python/boto3
parentdev-python/botocore: Bump to 1.27.78 (diff)
downloadgentoo-c7e09f25ee859a2bb5864325f2150f29987c5e9e.tar.gz
gentoo-c7e09f25ee859a2bb5864325f2150f29987c5e9e.tar.bz2
gentoo-c7e09f25ee859a2bb5864325f2150f29987c5e9e.zip
dev-python/boto3: Bump to 1.24.78
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.78.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index db7d691cf1ad..7438cbb0949a 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -8,3 +8,4 @@ DIST boto3-1.24.69.gh.tar.gz 536008 BLAKE2B 2a7c031423bac668110c0fdc17c66085c81c
DIST boto3-1.24.70.gh.tar.gz 536364 BLAKE2B b93c882f93093e453c82ea0cea298ccaeb9159271b8fc933bc884f1cc2fae14131a28cacfecf0c0f931c77d03d92acdac23a16acbdf4ceb1da0dca6859048616 SHA512 d7fbf4fdf44adf723d1325cb80c44c3e78df4d8c30b106d8256cdaf39bab442498c40624e2d9fb8f53af278518bb897bb9b2b040552f5420a82914f9083ec6bf
DIST boto3-1.24.74.gh.tar.gz 537890 BLAKE2B 5aa5b9fb754b9f0a1da6d05fb8419235617fa0cf50b2759c7b725cdface764921922366a1536c49ba5e283c3af10b2b987bfb3ef48f4b20882116957e6534f59 SHA512 5acbce2c828f268ca04dc5c38d192b9578ae7a16f8144262f8cb19b5364be5c39397e725cf4daed35405d31ac70907c271305320502f88ffb1f0dcfb49f3be0f
DIST boto3-1.24.75.gh.tar.gz 537974 BLAKE2B 00fbaca566c9dc782fa03f11c050477c32a19a1bc5c9e5e6472c99e12844b21e60493b1c1767c4943d600238366d2c30cfb2e67a3e275ce946a5eba6bce4a37c SHA512 0ba05ffa829b59eb983cb75724646f233aa969f032099854c76c736a5aac2a1328f2ec596033d8809d9347b5e7cec4f95ce639b743156fc2c40ee898485875d3
+DIST boto3-1.24.78.gh.tar.gz 538770 BLAKE2B ee690bceb7b04a8ef9bd4c3bea2abfa342ec7f5aa5cd60e03f2982f3dfb31a4f38847c687591677442abeb0a7197cb3e1125b3b1674223f165f31eb841968551 SHA512 002b366344be86bf1dccda41d4ae8d2421405de860dcc6e0a6b2889508026f91cfe7bbbfcaca55a59893233e1f7e756527dd0dcc2694f7fc8c9928601ae44fa4
diff --git a/dev-python/boto3/boto3-1.24.78.ebuild b/dev-python/boto3/boto3-1.24.78.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.78.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}