summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 08:21:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 10:05:27 +0200
commitdca685ebe8094d0cdc899721e9c8dfe11a020176 (patch)
tree94cc9d93210d1a5d89a44b9e9509ea7072a6b3d8 /dev-python/boto3
parentdev-python/botocore: Bump to 1.25.11 (diff)
downloadgentoo-dca685ebe8094d0cdc899721e9c8dfe11a020176.tar.gz
gentoo-dca685ebe8094d0cdc899721e9c8dfe11a020176.tar.bz2
gentoo-dca685ebe8094d0cdc899721e9c8dfe11a020176.zip
dev-python/boto3: Bump to 1.22.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.22.11.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 930b049583e6..d8f7173fb31a 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,4 +1,5 @@
DIST boto3-1.22.10.tar.gz 497369 BLAKE2B 448cb581fa31746083da4271436071b1ab5625207e5cc0560746beca9216a9748191206238a950a5a04cc178c20b744d19d3d99c1aefb775eaa79c5b96b75cbd SHA512 0e4ed0cf8f14997b4e61d926491fba05e4ec06dfae347e65ab3dceb48d61e24860e82fb922a7eac73e1e1322679418c96915c62f6279bad694685361d9970d7d
+DIST boto3-1.22.11.tar.gz 497893 BLAKE2B 07b757e4ab108eb70273dc3df082394dc730223417d1776f38c195831d2361578ed8722b107224b9e6c79685c7fedb02c386ea92c749d654a2f70b28d8de1e3e SHA512 f1367f66a93af59bcff2d29df6064440eac579e3aba4ab65083904de7a44b2c175fcfc2fd7836a8b0a425cf5519847c5e17075d42e82d46b2a0c4b46b7d5dabf
DIST boto3-1.22.4.tar.gz 495554 BLAKE2B 4c06e2101bcc96e4fab7e088f8593c7b1cfd2b07431d4cd062666df6c1f5d55d9b7fb594268e9a86c4793d35bc3d8de2644244728cf62833dfefb62525eedbdc SHA512 26dbd9ed1af900f7466a1767ada3fb8ee86fa09ca21733f857e2748d98525661fc76e69d75440fe913260e75245cf30298493417d055399a242af0aedaffd349
DIST boto3-1.22.7.tar.gz 496523 BLAKE2B 400370268e51b229bd3c465ccc43df93b713e3088baf76cbb7367cdc75b8374b787fee635cc921b431d5e1471a60a990d57a306d8ebdb14f0c462f211b323f99 SHA512 a7b56723a0fd692496a4e397ca29139f0813bfcea365877900441f01f38e5fd15d20a1642a5717940994bdfc840540d38b9a594e2510ab070ae62fadf9b4958b
DIST boto3-1.22.8.tar.gz 496856 BLAKE2B c7707eae7a5966dbe04e86c35270674f532286d3fbed46580836729988e55cdeba872496de750af89de6a7afdc6b19bbe4f8b9025580dc9b825cd04a87530b21 SHA512 43498179a59c2a1c9401f0629fbf0f3ff1dd51d2208ade828ff283b44be28fd539af68d4fb274e5e8c6c01bd03699872cd1a81d006f4c929dcdbf7227f77416f
diff --git a/dev-python/boto3/boto3-1.22.11.ebuild b/dev-python/boto3/boto3-1.22.11.ebuild
new file mode 100644
index 000000000000..fd6e0d8ebf01
--- /dev/null
+++ b/dev-python/boto3/boto3-1.22.11.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}