summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-22 07:06:29 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-22 07:54:18 +0200
commiteb7c25dc7a584e6fd9d8f21eeb2435f65d51bd76 (patch)
treee81b6998d5e83a2ca1faa0a844b0e3c2da0f2fe4 /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.98 (diff)
downloadgentoo-eb7c25dc7a584e6fd9d8f21eeb2435f65d51bd76.tar.gz
gentoo-eb7c25dc7a584e6fd9d8f21eeb2435f65d51bd76.tar.bz2
gentoo-eb7c25dc7a584e6fd9d8f21eeb2435f65d51bd76.zip
dev-python/boto3: Bump to 1.17.98
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.98.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index c141057f8f9b..7ee3d879fee0 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -19,3 +19,4 @@ DIST boto3-1.17.94.tar.gz 382448 BLAKE2B 84ea4989b47ff4b1adbcb1118bf1a18996d98d9
DIST boto3-1.17.95.tar.gz 383063 BLAKE2B 9d715ce7cf51daa806c0ed6044eca32c51dddc9114899e890e9745db51d574fea02515364cbab3fd82b9960dcc658c02bab89564c98ede13487ead75280c01a5 SHA512 63c78ea41bf79af23159aa8a97bf82ecd6c5b5075c1d077777679cc7ca17de4e91eb9abd19c152e5eeee2d5af47739ba0df3dbca6012c3836b577bc52e52eff4
DIST boto3-1.17.96.tar.gz 383485 BLAKE2B d962177eb5a693aad1900fbe6c44e20853deee74a31f188d1d12a34352d1376a5edcb84e854d8eddb8ce9dfe0aa46d8ec8c5998010a0f3a635d7b4b2ac46a1ea SHA512 c77a682b6895ddaceec21f9ad28eb08bda9eafa102cdb1024270247f9bfe849249c80bc586e18de4c1bd1410dabd165154b6c17655e8d56a16d38e009d695141
DIST boto3-1.17.97.tar.gz 383223 BLAKE2B 1a1b4e9f2c51d830762f27cf3e30038efb88322e300ac304d1cb88d5b7efc6af35ad9810cea7292c9807dcdfedb11ba039ee6d5dbb9162f2a1c6d6936ef75bcc SHA512 e74a59763cc9b8a51fd09121a790d29a7291d9380d4451c2e6af90902f18415a3780eeea7f7d63e052b295792b92c3cdd3b8597f7013241ebbbdb7e418cf73ce
+DIST boto3-1.17.98.tar.gz 383306 BLAKE2B f9fed22e11d2561a5a665105bdddffce2cea357f588200285ba4758809e6f64ded3ef4ad4eb10a52a1852df86d1098f752f432f5bd90a70669d569866262d638 SHA512 223de2234b235773138ffca02eed8187eaa2b74fa3c0822700bfcebe12da69078ab592ca77158448cb998d47dc63a20c79a3ce9dab2398c41faaf94a329c7cc3
diff --git a/dev-python/boto3/boto3-1.17.98.ebuild b/dev-python/boto3/boto3-1.17.98.ebuild
new file mode 100644
index 000000000000..666cbfa63e3f
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.98.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}