summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-14 04:36:38 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-14 06:26:09 +0200
commitf3a1890b5e753ab32f74dc5901c2e18089ef9292 (patch)
treee32f623e8956cc959aa20ec8934b04d842a4ae9c /dev-python/boto3
parentdev-python/botocore: Bump to 1.27.8 (diff)
downloadgentoo-f3a1890b5e753ab32f74dc5901c2e18089ef9292.tar.gz
gentoo-f3a1890b5e753ab32f74dc5901c2e18089ef9292.tar.bz2
gentoo-f3a1890b5e753ab32f74dc5901c2e18089ef9292.zip
dev-python/boto3: Bump to 1.24.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.8.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 8441ce125e43..422057d05b5f 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.24.4.gh.tar.gz 507020 BLAKE2B 2689aa84d0cc5a8c7978d18c480576015bb21
DIST boto3-1.24.5.gh.tar.gz 508100 BLAKE2B 5ad9e6325a507ea94738eebee58200b4c4e967db5afb5a3076ad55b64df8637f961074377375d9bf4df233c1d53444738e82a868515d04dbd9632dad0889e2c0 SHA512 9387c70c54e05b1007135a896e69934d128a31735cdf0b61ccadd9412c7be5d53259c60a2b4410157037f9a95afaf8ef4f4a97d35e290ff12b7deb125a73d903
DIST boto3-1.24.6.gh.tar.gz 508258 BLAKE2B 705b01006dfa63e386b39a0c4e791e0d9f2e4c5ae72bda3245843ba802556b1328214f80df788497d8b646882af816cfdba6d2769fe5bef82cbaf629fe9fcac6 SHA512 198df4e2f1e5f42bf0faa8baaea0bbc3d88fffda435afc3eccfdcc56940773dcdf43e8cb533a48265907bd118d8e969c7f9b37affb6508a8147ecee486017d92
DIST boto3-1.24.7.gh.tar.gz 508670 BLAKE2B d526f6a4dc4c6126c61ca7c9074b4341c742f84a6e95b38cd8a450fb74df379cee44513e1be6bc7cd0c8f728598d0ecfc06240120a8da71f75f86371498f5233 SHA512 4d57e38c18138b950f93a234132ac1d31c9a29ad00ca5e1298517d6b16ff2849802ce6cfeb8de390c2eb25086043d45e0276a7a563707595649ca1905367be52
+DIST boto3-1.24.8.gh.tar.gz 508760 BLAKE2B b904db3d57e2f7b6399670884f1c82d144840ed30b1a2e2955b33322ef24dba051aa1e19e49fcf3e449b8d0948d7715a37e300030c490a28a836e6c16923f82c SHA512 6abd7eb7591269c9b74c4cea1a8c52f4ccb1d7503ef2784e010ae20cd623bae340ff23301646dd51d1442a3a6a920e235362e2c6f872834fbb6233304c1a69fc
diff --git a/dev-python/boto3/boto3-1.24.8.ebuild b/dev-python/boto3/boto3-1.24.8.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.8.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}