summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-24 09:50:59 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-24 13:10:17 +0100
commit9fbb183c5d365a025db80b5f5460fb1ce6817dda (patch)
treee765a0d04f993a719b1cfc3a59e328af5d60f296 /dev-python/boto
parentdev-python/blosc: Add python3.5 support (diff)
downloadgentoo-9fbb183c5d365a025db80b5f5460fb1ce6817dda.tar.gz
gentoo-9fbb183c5d365a025db80b5f5460fb1ce6817dda.tar.bz2
gentoo-9fbb183c5d365a025db80b5f5460fb1ce6817dda.zip
dev-python/boto: Add python3.5 support
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/boto-2.38.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/boto/boto-2.38.0.ebuild b/dev-python/boto/boto-2.38.0.ebuild
index f966073020f4..5be2ca900074 100644
--- a/dev-python/boto/boto-2.38.0.ebuild
+++ b/dev-python/boto/boto-2.38.0.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1
@@ -16,7 +16,8 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="doc test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"