summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-03-27 19:07:03 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-03-27 20:59:39 +0000
commit3a7287f17ed699a7c33873e7334ff4e29330aea9 (patch)
tree58d0c7ba48a409858184a7e3b17c1bac37f77af9 /dev-python/botocore/botocore-1.12.122.ebuild
parentdev-python/botocore: 9999: update copyright line (diff)
downloadgentoo-3a7287f17ed699a7c33873e7334ff4e29330aea9.tar.gz
gentoo-3a7287f17ed699a7c33873e7334ff4e29330aea9.tar.bz2
gentoo-3a7287f17ed699a7c33873e7334ff4e29330aea9.zip
dev-python/botocore: add new version 1.12.122
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'dev-python/botocore/botocore-1.12.122.ebuild')
-rw-r--r--dev-python/botocore/botocore-1.12.122.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/botocore/botocore-1.12.122.ebuild b/dev-python/botocore/botocore-1.12.122.ebuild
new file mode 100644
index 000000000000..ecf278301165
--- /dev/null
+++ b/dev-python/botocore/botocore-1.12.122.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/unit || die "unit tests failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/functional || die "functional tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}