summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-09 15:33:27 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-03-09 16:01:32 +0100
commitce7cdfc2f9492d814854598a751de06581b8804d (patch)
tree492526195da3ecd09c13689b0cd17f5f05ca9aea /dev-python/botocore/botocore-1.15.16.ebuild
parentnet-firewall/shorewall: bump to v5.2.3.7 (diff)
downloadgentoo-ce7cdfc2f9492d814854598a751de06581b8804d.tar.gz
gentoo-ce7cdfc2f9492d814854598a751de06581b8804d.tar.bz2
gentoo-ce7cdfc2f9492d814854598a751de06581b8804d.zip
dev-python/botocore: bump to v1.15.16
Package-Manager: Portage-2.3.91, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/botocore/botocore-1.15.16.ebuild')
-rw-r--r--dev-python/botocore/botocore-1.15.16.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/botocore/botocore-1.15.16.ebuild b/dev-python/botocore/botocore-1.15.16.ebuild
new file mode 100644
index 000000000000..f9ce3c85acf8
--- /dev/null
+++ b/dev-python/botocore/botocore-1.15.16.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/unit || die "unit tests failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/functional || die "functional tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}