summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-05-09 18:01:31 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-05-09 18:01:31 +0200
commit01fdebe2c6bf48aadb1b88be7169b32acb5a4443 (patch)
tree21fa53ec005680e62ea811dbc3ecb2d2ed6bb927 /dev-python/botocore
parentFixed CPE tag for sys-boot/grub (diff)
downloadgentoo-01fdebe2c6bf48aadb1b88be7169b32acb5a4443.tar.gz
gentoo-01fdebe2c6bf48aadb1b88be7169b32acb5a4443.tar.bz2
gentoo-01fdebe2c6bf48aadb1b88be7169b32acb5a4443.zip
dev-python/botocore: bump to v1.16.6
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.16.6.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 49e354dea744..5a0e3c32ac30 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST botocore-1.12.122.tar.gz 5492931 BLAKE2B 05371245cd0de404713f920d0651f9bbdc
DIST botocore-1.15.16.tar.gz 6173930 BLAKE2B 70e185faa9fa3f8537e38e4db8c263f5bfb0430d827e1093d41fdae8a16d6975071d3eec0eddde41d92044eebed92396d65f70eaf21a4ea2e6a1b464498c7f15 SHA512 574f0fc8cfa34e16b9933a7c7dd9fc9a95f713f8693507eac5598e73775def6df209b2883abf5a13e68327bf1e89508fce5d37074cd3a0173ab5cd1e35372409
DIST botocore-1.15.32.tar.gz 6261957 BLAKE2B 7825e7d6315cae3578155825e0b5cb3961e5548021d63dad1747903c8f55bede03c4fdb0a07b724e2816ef294a890e85a648bae313620ab4156fd2a28d4e517b SHA512 865612fa52aae3bf08ee74b52a3fe685d7308d0d86bd438851e0b9db639ba3f6430211a7863c1b0737c0af0afc6ba760b2ccfd0103d303e87758317f773cef6d
DIST botocore-1.15.48.tar.gz 6336322 BLAKE2B 0d25424e82fcbf1376bb1eb9cac9eeb7a45d08698f39563f635a34b1b24bc6823c5f2b08b6a40a0fc9b54b0404b8f5dd7d07fc21e0c7e0c489fe172e7f29a936 SHA512 91d86731909be5828e38a69e32e5189fbd0357378c51a04f60efbcfbb1b6c0c01151c982fc32619e3be240f5df881e5342bbba6b290b3092d9fe11ce9e3b28d0
+DIST botocore-1.16.6.tar.gz 6386032 BLAKE2B e909e2fa021d5b1be333a31758af408cdc6e11224addefac31b87b8ce9983350aeaaf862feaf040490fad8eb87d7dde800bd8a77156410e6a734f567e2cc1055 SHA512 1f265a0a8adb7f0172f02448d3be5aeacf11e3fb7023da8d81e6d19c39d97cac99cfe3a70997e682deb44a4fd78304e4a0c1df43787f3139bbccbe852c682a82
diff --git a/dev-python/botocore/botocore-1.16.6.ebuild b/dev-python/botocore/botocore-1.16.6.ebuild
new file mode 100644
index 000000000000..f9ce3c85acf8
--- /dev/null
+++ b/dev-python/botocore/botocore-1.16.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/unit || die "unit tests failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/functional || die "functional tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}