summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-27 07:52:36 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-27 09:00:20 +0300
commit66ce9bebf5b852b8dea383a198d1077df78db649 (patch)
tree30fc395072b8ecff5ead1e8a2e2d71fda0dad11c /dev-python/botocore
parentx11-wm/i3: Switch from pcre to pcre2 (diff)
downloadgentoo-66ce9bebf5b852b8dea383a198d1077df78db649.tar.gz
gentoo-66ce9bebf5b852b8dea383a198d1077df78db649.tar.bz2
gentoo-66ce9bebf5b852b8dea383a198d1077df78db649.zip
dev-python/botocore: add 1.27.81
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.27.81.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 308c2013e260..37c85f737008 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -11,3 +11,4 @@ DIST botocore-1.27.75.gh.tar.gz 9628845 BLAKE2B dcce68d2d24e621d8d56d2f3417a5bbc
DIST botocore-1.27.78.gh.tar.gz 9639497 BLAKE2B 38b3286227941216db66453201b73366ab28722f6f6e08388419b9db7bd4b25aad2c379cee6438ecc0c25fdbb732827117954454280e4aa367f1d579352f464d SHA512 bf182ac90c0d392a32f2d117145d2cbcf019ddbd3fed1205228a9b5721b08296f8948668c47b07feab6eb2ad2cf65f92a31d782c5ff3ecdf727466f7889c466d
DIST botocore-1.27.79.gh.tar.gz 9640519 BLAKE2B 35c2960c2c3e92f78e6903b102dbefe26e5cca1b25610abb059c81382dc816dbfbb260db98a921886e9cd2aff6d172396d5853c0529a7558d86889857fae75a2 SHA512 2e0c110f55aa9dd74fcfd3da3f87d14cb5ea53f67b7c867f13a7649809cee9cf3a55631e2daffa94da7ca709e5ad49db708a7821ffff8ccf992ebfbf9d5bbae9
DIST botocore-1.27.80.gh.tar.gz 9643079 BLAKE2B feec0b34c39b358eaff7f947fe83fc6dcd9926771b465c092e8071c334382d07d51a88fda775fc9fadae2544ac2f3e37c814bc9b8729730955b95d3efdf16b7b SHA512 f38ee5b252051a8208964387ff1550489c5900605d2aa5c69dc2d1229411015af1edaa51e9df4d56895c3fd2b4a56cca5179c1fd5aecbf5032ab80ce4c8f8b8e
+DIST botocore-1.27.81.gh.tar.gz 9663876 BLAKE2B 35da266dee35d717c0190378d4e73dbc018b9973a768476c4e675942e6f730901e7bcfbd2f700589877b1eb1fa85a20a29932c62d20a37a957045ea32cada7d1 SHA512 9ba40ddc75f812ce255ff668e9299313eaed44fb86b130a84ac624ace35ffd03bbb95fd88ce0848f8f8f9e0c48547e4433af6746f2063d57dd5d43d32bc7810e
diff --git a/dev-python/botocore/botocore-1.27.81.ebuild b/dev-python/botocore/botocore-1.27.81.ebuild
new file mode 100644
index 000000000000..d1a6948e70e5
--- /dev/null
+++ b/dev-python/botocore/botocore-1.27.81.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}