summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-04-29 00:07:00 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-04-29 00:07:59 +0200
commit75a2bd9d949cca700fa9819bc7649273a1082c40 (patch)
tree16656c8097217fa5001bdcfad69de959530917dc /dev-python/botocore
parentsys-kernel/linux-firmware: drop old (diff)
downloadgentoo-75a2bd9d949cca700fa9819bc7649273a1082c40.tar.gz
gentoo-75a2bd9d949cca700fa9819bc7649273a1082c40.tar.bz2
gentoo-75a2bd9d949cca700fa9819bc7649273a1082c40.zip
dev-python/botocore: bump to v1.15.48
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.15.48.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 29f4d4360e47..49e354dea744 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.12.122.tar.gz 5492931 BLAKE2B 05371245cd0de404713f920d0651f9bbdcabe9508c5e27f692adc4cda7ac2f7fba24b2b95a26b788e4960b01553c1746f08b9db4f38e4629c5703fd6872893be SHA512 f92581ac6b8a46d4af8b55b391e6e75c452f83a4ffde6c940c9f85b2215a3eda44e8b2672f469769b4d9a0d7ac2823540f45c1822279b6264d016986f2b06c53
DIST botocore-1.15.16.tar.gz 6173930 BLAKE2B 70e185faa9fa3f8537e38e4db8c263f5bfb0430d827e1093d41fdae8a16d6975071d3eec0eddde41d92044eebed92396d65f70eaf21a4ea2e6a1b464498c7f15 SHA512 574f0fc8cfa34e16b9933a7c7dd9fc9a95f713f8693507eac5598e73775def6df209b2883abf5a13e68327bf1e89508fce5d37074cd3a0173ab5cd1e35372409
DIST botocore-1.15.32.tar.gz 6261957 BLAKE2B 7825e7d6315cae3578155825e0b5cb3961e5548021d63dad1747903c8f55bede03c4fdb0a07b724e2816ef294a890e85a648bae313620ab4156fd2a28d4e517b SHA512 865612fa52aae3bf08ee74b52a3fe685d7308d0d86bd438851e0b9db639ba3f6430211a7863c1b0737c0af0afc6ba760b2ccfd0103d303e87758317f773cef6d
+DIST botocore-1.15.48.tar.gz 6336322 BLAKE2B 0d25424e82fcbf1376bb1eb9cac9eeb7a45d08698f39563f635a34b1b24bc6823c5f2b08b6a40a0fc9b54b0404b8f5dd7d07fc21e0c7e0c489fe172e7f29a936 SHA512 91d86731909be5828e38a69e32e5189fbd0357378c51a04f60efbcfbb1b6c0c01151c982fc32619e3be240f5df881e5342bbba6b290b3092d9fe11ce9e3b28d0
diff --git a/dev-python/botocore/botocore-1.15.48.ebuild b/dev-python/botocore/botocore-1.15.48.ebuild
new file mode 100644
index 000000000000..f9ce3c85acf8
--- /dev/null
+++ b/dev-python/botocore/botocore-1.15.48.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/unit || die "unit tests failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/functional || die "functional tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}