summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-15 07:21:56 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-15 07:36:48 +0200
commit795ee8c943b3d85eb06c58b943587c1451ff1715 (patch)
tree0497422cdf41ab749d8a38396371c59771346c0d /dev-python/botocore
parentdev-python/m2crypto: Bump to 0.38.0 (diff)
downloadgentoo-795ee8c943b3d85eb06c58b943587c1451ff1715.tar.gz
gentoo-795ee8c943b3d85eb06c58b943587c1451ff1715.tar.bz2
gentoo-795ee8c943b3d85eb06c58b943587c1451ff1715.zip
dev-python/botocore: Bump to 1.20.94
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.94.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index c84fca9a69e1..1c7a293a9ef3 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -15,3 +15,4 @@ DIST botocore-1.20.90.tar.gz 7810567 BLAKE2B f34ce1e4ed16254585a90e3ba1674a35909
DIST botocore-1.20.91.tar.gz 7822478 BLAKE2B d76b3a944f951a9722e59d28218e24eacbcc9282235df6adbbf9ac01b12dc96e446a7dbec06ab08433513a3f1dd1f39ac8db85c4aa3cfcd99348fa57e85b2246 SHA512 730b664b050db5df7c9f9f3ab89e7c7f541b0c921a0a6f38f4d0d7a4594f89b61929d5251799c2cf08bda1107567c636d036379b328db788178ae7af18157366
DIST botocore-1.20.92.tar.gz 7826845 BLAKE2B 8568b8be7440807fae48f735198059356764c7f36db1dfcf73801379ea90b728bb02a086e19a202bb5b3a7c05886edbc22ca729a1ea43ac1f38ad96b64a6c28b SHA512 0cba710b28086b4e83c6269e74ca3531b26497d438e28b8ea285f7fbee0da43545134d22fe5fb300d3c77d9c933882b1f00cde797c470e6af73553c191cebd66
DIST botocore-1.20.93.tar.gz 7827854 BLAKE2B 6297172731db3367d5d769c38de4d8ba8e36eb8c1e870d8f31c3175944d32f52d4e51f69d533853d0c8ea2c0bd2dbacb971a12aa18537bf099c9812481108d9f SHA512 2d38de5fd92bd17df029f93254e8ea26fcf1cefda274d479cdbe8919c862d32c0a18cca165fe65c4125adbbaecc1909dc8da576a0b0fc7d47dc72cd3fd3db6cf
+DIST botocore-1.20.94.tar.gz 7830564 BLAKE2B 4c52bb0f782a4560c1c966ede26a5741428f5b06aea8a46f76956b7ebebeec92c6eecd62fd3064a3eeb206c68116a64104222dc141d860cc9d1c53eb37567c24 SHA512 1dbb52626b03f82b48cdf76da0e0138b11d47c9f6aef64a164c7489232a46af4f2d214fef5d132a1c656f2728608cecd23b4a781f58252ee7a69c7efe853d4f3
diff --git a/dev-python/botocore/botocore-1.20.94.ebuild b/dev-python/botocore/botocore-1.20.94.ebuild
new file mode 100644
index 000000000000..762144aabf71
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.94.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}