summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-02 08:15:58 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-02 10:29:12 +0200
commit7b5e075badccf847a567bd2fb11f3a87d4169bbb (patch)
treed3341cca7cbcad622f1833ea51ca91b203765331 /dev-python/botocore
parentdev-python/cloudpickle: Bump to 1.5.0 (diff)
downloadgentoo-7b5e075badccf847a567bd2fb11f3a87d4169bbb.tar.gz
gentoo-7b5e075badccf847a567bd2fb11f3a87d4169bbb.tar.bz2
gentoo-7b5e075badccf847a567bd2fb11f3a87d4169bbb.zip
dev-python/botocore: Bump to 1.17.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.17.15.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 6abb3c4291d9..3f4616ecd932 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -9,6 +9,7 @@ DIST botocore-1.16.6.tar.gz 6386032 BLAKE2B e909e2fa021d5b1be333a31758af408cdc6e
DIST botocore-1.16.7.tar.gz 6391893 BLAKE2B 19a8770ef1058e5601a1c292e2e17e1625e4d5d0d1845b59bbd403a2c285da1a774935e9d1e1fa7ca26a1e3c4703b29fcbb2f021a7251aa3ca756c80b2ba0461 SHA512 0ab2b4ff4096049cd92b96c710a38867a53b2dba0f07a319ec1a2f9b3cbce60776026c62e3eaaebe571b6ad26eb5c1c258b2dd350a444d30e54b342bcd675768
DIST botocore-1.17.0.tar.gz 6478558 BLAKE2B 761ff2d57079a52ce38a6d56639fb0771d1fc4fb6a3494badecaacd4cea1ef74a69fe23d9fe62827993a3b6c33b963a2a199300f37fa3e7dc42433135c00f035 SHA512 a43b2f99e44ef9de3cf740b8fc1d74976d9ff6831639229a704f9300011405861789c9af26ea657f64244f5d67cff19aa94f95e5d2df73ee4f2dc10ccdeabae3
DIST botocore-1.17.11.tar.gz 6508848 BLAKE2B 91e38db3868fb2cba9ffa6a1dfc95bd6557bb5ed8844a148b99603fb8557dc269fd652bfac3132d0b0b07fbb9063ed2762ad461cb75280cef7570bd251268029 SHA512 7ae6129985b58d1f24d0892a4506681af23d45d68be217aa5ddd06cdc2e8440edab3983f3f7dd0bb1993275d2ae0cfdd5406aaa7643f807dca4ed3ed71bf9eee
+DIST botocore-1.17.15.tar.gz 6530455 BLAKE2B d402845e3c0f434e39b1c1ab80378eb2d5f113b99be83471b89cc7264a2c696cfb38b25960f8c0eb3d721147c706f43c1db02287c8ef4ae4ae33394f2fc82473 SHA512 7a8ff75e83fa8df17d79cb3ede9faf2a7eb4c2bfa338411f0186d6c30946aaa247c14ddfc91c9d7ee6d1639696ca5e808bf4131ad2182608ecd99ef0e97175c1
DIST botocore-1.17.2.tar.gz 6481390 BLAKE2B 009f8857be93c2fccb52e83176614401ae89835ea32fd0043248f7f66765d06e44df72ed31b5370cc1ed106cf45b531f4e4e7e7cbc3dc1d6e1524cb7914654d4 SHA512 ff19b1708686cbb574b01c9924a6acb7eaf7607b5f19a759d5c1dc1f7a7efae960e0c81d26d384101da5aaddc3bf0d8b4800d8908af34392d23779d4b9064487
DIST botocore-1.17.5.tar.gz 6491397 BLAKE2B e6d45050e0f9d9919edff7dcea0866c9360fc8b8a09a82bcb6636621b49d7c9d06025639d8acf8740bf6d272371cabc9afff51e48214d240f1e81cd76abcab65 SHA512 2cf87d79a50f10d386907a0ef5b0e427b299b342d3661dfa64860828a0854dcd7f2ef3e0febdc30772aabf93efb39f4f35d52d3f28aec641e886fb5c05e30a3a
DIST botocore-1.17.8.tar.gz 6499259 BLAKE2B bbec0755ac5c96f8b86d9391db36b58c28a2eff61b69ddccbbfcf0d7b349e1b5c99a2ab3619e50c6eda6a781e5361dd11f674126a596e23f505fde81a9b77949 SHA512 3f0c06e5fb335cc33ed589205ca378d4270d26dfb7f4b6196953205d24de4f71bf09c47b722449e51325d7643be6767f7a542d79765649ea3581247bc219f88d
diff --git a/dev-python/botocore/botocore-1.17.15.ebuild b/dev-python/botocore/botocore-1.17.15.ebuild
new file mode 100644
index 000000000000..c08c6f6ff899
--- /dev/null
+++ b/dev-python/botocore/botocore-1.17.15.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+ "${FILESDIR}/botocore-1.16.7-unlock-deps.patch"
+)
+
+distutils_enable_sphinx docs \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # py3.9
+ find -name '*.py' -exec \
+ sed -i -e 's:cElementTree:ElementTree:' {} + || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}