summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-14 08:26:23 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-14 11:21:19 +0100
commit89074570c684e1032389862cb10d419a36acbd41 (patch)
treedc90dce394ea61aa67c61d980e75863a9fe1ad18 /dev-python/botocore
parentdev-libs/xxhash: version bump to 0.8.1 (diff)
downloadgentoo-89074570c684e1032389862cb10d419a36acbd41.tar.gz
gentoo-89074570c684e1032389862cb10d419a36acbd41.tar.bz2
gentoo-89074570c684e1032389862cb10d419a36acbd41.zip
dev-python/botocore: Bump to 1.23.24
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.23.24.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 9c3b9e900eaf..a72a2f123c7e 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -8,4 +8,5 @@ DIST botocore-1.23.20.tar.gz 8668630 BLAKE2B 3b6b65dd73886bf05ec52fd8e2a3d139f29
DIST botocore-1.23.21.tar.gz 8669970 BLAKE2B 18dbd124834a16e5ebf925e8bd1c38ac86a87bbf2c7f10afb2b885833d95bf16893ea287585b3c70d656b888fd59e02b8e1ab4b9eec06d57ba9d1693e1a3fed2 SHA512 557ea1915a83a683d02ecba2731a274422d18640b4f063e4aa7bb68987e477106495143575f2436cfda3c945164de91b61c874b8d8768aee80109d360bf72211
DIST botocore-1.23.22.tar.gz 8674742 BLAKE2B 8b49d05579fff8bed30e5868e9cc3dd7f1ffded86e34dc19a190b3cd249b76291b75b2a9b78d64aef921c8e3c22e8348e35d20a5d6afae1f10681ca4ec679e4d SHA512 b5244731c7ddb70ef55df41439294e9760342194db93d3044cbd0c2a845205ebd693ec76e4cb7de297c0f951ab193fd3f049897ff8e2c5903ffb81c7d003acba
DIST botocore-1.23.23.tar.gz 8679727 BLAKE2B 89e54120caec616ffb539ef9df93923d9514ad29ba2430d36dbfa5392325be181d9c8c132983d062f120ce0629a411f3136e55fec5fa2c3e7299a9551652448d SHA512 a4e14b680fd71a6c5ec499ed9c75f55a51cffa1f6ea569e3a3d231646f90e4729a7fbacf9b6a0ee5ab0b5321b8078970a0db2a74087500991a65d164091b2ab2
+DIST botocore-1.23.24.tar.gz 8677151 BLAKE2B c12382994208f673cfcfa71e17fed028abfd299595734af7f604612fc6f1fc45dd67a1de17d36accf831d296a5eafedb75b6249e219fb3de75a6a4dbb6e41d59 SHA512 a03b64236c61fcfc7111d8218fa5cb6a305522c20f8eee28dc83983560cfd5a32c9bf5933e6005b49f188b7b673614389a9b79fd5f81701acb09b0816e5bac54
DIST botocore-1.23.5.tar.gz 8374467 BLAKE2B 467092e7d8aa5ccb756132669049865445a47205913964c1c944b20caaf100b1efdd1bf3af9c5416ff079b487e6d4d08ffe6208e2b352d09655cc5be21c88739 SHA512 6afca19b724f9019f21e5993ce970d605b95d31c1a4e969ec1b4080510a5a120b3fa0cfd5ade973a9203bd6b7983a3dbca2f7a03108a9167392efd60d5e2fe9b
diff --git a/dev-python/botocore/botocore-1.23.24.ebuild b/dev-python/botocore/botocore-1.23.24.ebuild
new file mode 100644
index 000000000000..5babe7de7679
--- /dev/null
+++ b/dev-python/botocore/botocore-1.23.24.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ distutils_install_for_testing --via-venv
+ epytest tests/{functional,unit}
+}