summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-23 21:45:11 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-23 23:04:49 +0100
commitbf4f3e89493fd3d03de141147033339ee532f517 (patch)
tree08daa46c3a22faa75a3b09c4ee277113b4d80914 /dev-python/botocore
parentxfce-base/xfwm4: Stabilize 4.16.1-r1 ppc, #826938 (diff)
downloadgentoo-bf4f3e89493fd3d03de141147033339ee532f517.tar.gz
gentoo-bf4f3e89493fd3d03de141147033339ee532f517.tar.bz2
gentoo-bf4f3e89493fd3d03de141147033339ee532f517.zip
dev-python/botocore: Bump to 1.23.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.23.12.ebuild65
-rw-r--r--dev-python/botocore/botocore-9999.ebuild15
3 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index b48d19bc9e87..0ae19080008d 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,6 +3,7 @@ DIST botocore-1.22.12.tar.gz 8343683 BLAKE2B df7b2c86f226df14dc8181e8506acc7dd66
DIST botocore-1.22.5.tar.gz 8301083 BLAKE2B 91f9d38e7c5bcb0b8f58c04547ad45489f58d2240c6b7301cf632969a4a73cf4a1d51c8c68c8def27653c10041d2163ad7ca800dcf6fd07972b506bf2566cae3 SHA512 710a9eeee03dc79ca4ffacc4974f09ca769e1e3b8cb143f6f0349240dd8c2af8ee526a1dadb7310a26019363f683fc4149cb4c73d8b94a856a384fab7f84fb5c
DIST botocore-1.23.10.tar.gz 8429267 BLAKE2B bcad034d600f17317e1036225a789c143d75ee2375965df60b3398d898fb49e5ceee7a5ac99cd7fb5f44f2bd89da7cee9406df6b493a53c93fcce5363d7735e5 SHA512 c2782cb8e360f1a921a0e630f2a6cc0f97f1ff0a974e89d95c0b602f201ebffe29a507759e9a83153cc3d9797f057d7bc6e4f6568f6965a7448be04b479c5b55
DIST botocore-1.23.11.tar.gz 8445108 BLAKE2B 16e486ff61e2b7822d6db74ed5829ce4e0cdc69b32c6d6b08b5790eca9856c409844b67a0545f9c22e8cbd90bfb5f6f0b0f8be1f1924f9814235390eca71d853 SHA512 625fd439da1bab2be4bf4621ace23ad5c815fe80933dc89d1489016424eb53dcaa2b8f476cf920ae0a800c05bce9dbef594e794c7131cce4e81eee81381f1f64
+DIST botocore-1.23.12.tar.gz 8456254 BLAKE2B 64119372aca49f1a18835b518ca2474b9e1bcfc0f03e13ffa749b04c6658f229d096751d9bd87b0f5852afd62cbfbe8eacd05c1d91e1c423171374a341daca43 SHA512 e54fc3054093bb41d566d24e06c97ffbd68cfed68183564efe67fb5a70f90acd14d95345874a80fa82faa19cafaa3f84839c5cd8443e171a17029279d1ecf949
DIST botocore-1.23.5.tar.gz 8374467 BLAKE2B 467092e7d8aa5ccb756132669049865445a47205913964c1c944b20caaf100b1efdd1bf3af9c5416ff079b487e6d4d08ffe6208e2b352d09655cc5be21c88739 SHA512 6afca19b724f9019f21e5993ce970d605b95d31c1a4e969ec1b4080510a5a120b3fa0cfd5ade973a9203bd6b7983a3dbca2f7a03108a9167392efd60d5e2fe9b
DIST botocore-1.23.6.tar.gz 8387968 BLAKE2B 415a177d591a0ef369f17b8f02563be0fb53bc4e65c2767f41ca11300939585a10146874b6ac5297cdd3dcb36cf6fd2065fd09f3c612c4ba1d954b03a5b15579 SHA512 a46e45b7bb67d7c4bcc5508f38448b9ed3778ed6b6080239459b22b7f753adaf12e8d64496f7d7c71b33bb17ae1744000e9269ea0f545286e56fabe39e7f0340
DIST botocore-1.23.7.tar.gz 8391467 BLAKE2B dd6cad44c1b8109b76c44bfffa45e74da0fbeaa027429860640e33134dc5f6e5bb813b46d8b662d80b89af46d437c6fb962f0e0ab1edbeca3ee790f3b6d029bf SHA512 a3270da3b6d906bc2372af221400e14039868598ccd56f40f976bcc2638f300ae9990ff367f76e5b5cdf8d46a8a37716865f9a40ca7e79b73a5b8dbcb2b1af7f
diff --git a/dev-python/botocore/botocore-1.23.12.ebuild b/dev-python/botocore/botocore-1.23.12.ebuild
new file mode 100644
index 000000000000..80a198d56414
--- /dev/null
+++ b/dev-python/botocore/botocore-1.23.12.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ distutils_install_for_testing --via-venv
+ epytest tests/{functional,unit}
+}
diff --git a/dev-python/botocore/botocore-9999.ebuild b/dev-python/botocore/botocore-9999.ebuild
index 638620b2cbc8..80a198d56414 100644
--- a/dev-python/botocore/botocore-9999.ebuild
+++ b/dev-python/botocore/botocore-9999.ebuild
@@ -42,9 +42,24 @@ distutils_enable_tests pytest
src_prepare() {
# unpin deps
sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
distutils-r1_src_prepare
}
python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ distutils_install_for_testing --via-venv
epytest tests/{functional,unit}
}