summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-16 09:18:05 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-16 11:09:40 +0100
commitcb544fe097b3ae8604ad3fe8eeaf6a603d76f315 (patch)
tree156fda94a3e8f53df77f2fd81328456914e7ba8f /dev-python/botocore
parentnet-im/signal-desktop-bin: remove old version (diff)
downloadgentoo-cb544fe097b3ae8604ad3fe8eeaf6a603d76f315.tar.gz
gentoo-cb544fe097b3ae8604ad3fe8eeaf6a603d76f315.tar.bz2
gentoo-cb544fe097b3ae8604ad3fe8eeaf6a603d76f315.zip
dev-python/botocore: Bump to 1.19.37
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.37.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index c332fcea1ee0..955630b3e554 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -11,4 +11,5 @@ DIST botocore-1.19.28.tar.gz 7208608 BLAKE2B eab5731c530747421186c3e24cc0cb0f5b1
DIST botocore-1.19.29.tar.gz 7219708 BLAKE2B c5468be09300edf1acfb82780ad026ad78537b641b9f8f9384c41397e293a51559259c64925dac2852b888a28b49c23b7802b2c3adaca097424029fe9717044c SHA512 674f76a443541ff3665dbb1834ac69f8776e497526001db9bd229f22ea2137452c3bf954d8a6b74a732bd9e7212545cae19c9058357a38c357ed09d89c9c1cc5
DIST botocore-1.19.30.tar.gz 7224700 BLAKE2B 50712be7e6e4a8a22607d567a8d227bbc6d9a7156c245a9faa5adf0e94364d5e5738dd558534e072d071e88315fd79555454fd5f36dfb5d309effca6a39f2247 SHA512 8d9a0becad072ac01e04c1709e8851344bbcd35ecb6c269cace7c229e3b2e48b8fd91ca31be96c67831030a75a63027e8700772601a65eb529bcfd8a58434b6c
DIST botocore-1.19.36.tar.gz 7291325 BLAKE2B d1f79298a0f47d704418cac8390a5d500b1f300fc9bdbc0b215a3630adb70c29a951c6dff2a6ebfde42872cbc3af4c442d09fa0233b2c957521e6a5e05816c60 SHA512 420ad7c59496b2b74ba6ecde8dc40ac3e47c5676335f7471448fcdde5b70bda3bd7516963788d8a7a940aaa9cf488b6529e6fbd2842806f58520cd8e2dc15a60
+DIST botocore-1.19.37.tar.gz 7335789 BLAKE2B 3df00ad1f0d34f8f8408741b503fafdf9bdaacd9f5b0c52ffbc0b3172e7b0d01e741a076430268c55c39f1fe050a9b8bcc2d183eb54830886c7f3f050a22c408 SHA512 53ff17dcba3e72910709de7fe4504a04a507a708c2674039cfb682276ea7f8f46d3afeadbb41103d02141183d6216aab5964b0df98033cd12946ed1c83373aaf
DIST botocore-1.19.9.tar.gz 6972834 BLAKE2B 3407c056c7995cc1ccb1b5b4c5b3a6254e38672b52e7889a7a022520283416e4dfcabd05c8ca0ed78e4624c7a20c9f43bfde87a76d7a72660b4c95256e4f9ca4 SHA512 8433f22ae7652e524a82da8d2ccda48da9eef44788333898b7526335d57a7757b80754f0d5c6a2c84ec3bde2ec9fc7da5cf872cbda7286f620b4f4878fe9a583
diff --git a/dev-python/botocore/botocore-1.19.37.ebuild b/dev-python/botocore/botocore-1.19.37.ebuild
new file mode 100644
index 000000000000..ca40b64d111f
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.37.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}