summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-26 20:45:47 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-26 20:54:41 +0200
commitc04c0ed836eec2a9e92a781b23693f21dc684cdd (patch)
tree633be0e76c4ea081c80ebf9513f3a89dd18b6a3e /dev-python/bottle
parentdev-libs/gnulib-2022.05.26.07.24.56: version bump (diff)
downloadgentoo-c04c0ed836eec2a9e92a781b23693f21dc684cdd.tar.gz
gentoo-c04c0ed836eec2a9e92a781b23693f21dc684cdd.tar.bz2
gentoo-c04c0ed836eec2a9e92a781b23693f21dc684cdd.zip
dev-python/bottle: Bump to 0.12.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/Manifest1
-rw-r--r--dev-python/bottle/bottle-0.12.20.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/bottle/Manifest b/dev-python/bottle/Manifest
index 81c2815a03e3..0e27be5f5029 100644
--- a/dev-python/bottle/Manifest
+++ b/dev-python/bottle/Manifest
@@ -1 +1,2 @@
DIST bottle-0.12.19.tar.gz 73142 BLAKE2B e59d7a507d3401869ba4953a48274062fc56226afa2f7aad596b4ef4352e4a79cea2d224dfe32d7ce014e4f4a3ba088d0e7a0886f64a84bb6b78571e953fa3c3 SHA512 e5d2f6a32d1b89ae3cc9607456c0614db2b58882c6d36273d695c51d3d77b1858cac4d914dbf19bca3b74be68c197aa6473f162e40d9b7ae2af3a084a28c2637
+DIST bottle-0.12.20.tar.gz 74235 BLAKE2B 8d6c03ac9a0330fa13e474fcb6bb985d663d3c4c1c2cd6ca24a1224efd3072d4897efafc095af13f8231b99d705ae252fbed29ebe8e18dc5c9db7318a9c749c7 SHA512 149355d39ac1370a3b6c1999756ac2c7eb98ef04cf99df7099a6c84112e1ff06a0cac4612843750499633a136ea2ddfb1a5d594ba03d7ee63cf7cae9aceba823
diff --git a/dev-python/bottle/bottle-0.12.20.ebuild b/dev-python/bottle/bottle-0.12.20.ebuild
new file mode 100644
index 000000000000..a1d390cb6eff
--- /dev/null
+++ b/dev-python/bottle/bottle-0.12.20.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="
+ https://bottlepy.org/
+ https://github.com/bottlepy/bottle/
+ https://pypi.org/project/bottle/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/mako[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/bottle-0.12.8-py3.5-backport.patch
+ "${FILESDIR}"/bottle-0.12.19-py311.patch
+)
+
+python_prepare_all() {
+ sed -i -e '/scripts/d' setup.py || die
+
+ # Remove test file requring connection to network
+ rm test/test_server.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" test/testall.py || die "tests failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Templating support" dev-python/mako
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}