summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-11-09 11:13:01 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-11-09 11:13:01 +0700
commitbb64c22046cf54b997451f455b97c0902b32fc09 (patch)
treef2398b87f8595b374d8b339cf241853cc314bffe /dev-python/bpython/bpython-0.22.1.ebuild
parentdev-libs/ntl: support LIBTOOL="slibtool-shared". (diff)
downloadgentoo-bb64c22046cf54b997451f455b97c0902b32fc09.tar.gz
gentoo-bb64c22046cf54b997451f455b97c0902b32fc09.tar.bz2
gentoo-bb64c22046cf54b997451f455b97c0902b32fc09.zip
dev-python/bpython: bump to 0.22.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/bpython/bpython-0.22.1.ebuild')
-rw-r--r--dev-python/bpython/bpython-0.22.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/bpython/bpython-0.22.1.ebuild b/dev-python/bpython/bpython-0.22.1.ebuild
new file mode 100644
index 000000000000..53cc9af10082
--- /dev/null
+++ b/dev-python/bpython/bpython-0.22.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
+HOMEPAGE="https://www.bpython-interpreter.org/ https://github.com/bpython/bpython https://pypi.org/project/bpython/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="clipboard +jedi urwid watch"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/curtsies-0.3.5[${PYTHON_USEDEP}]
+ dev-python/cwcwidth[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ clipboard? ( dev-python/pyperclip[${PYTHON_USEDEP}] )
+ jedi? ( dev-python/jedi[${PYTHON_USEDEP}] )
+ urwid? ( dev-python/urwid[${PYTHON_USEDEP}] )
+ watch? ( dev-python/watchdog[${PYTHON_USEDEP}] )
+ "
+# sphinx is used implicitly to build manpages
+BDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ "
+
+DOCS=( AUTHORS.rst CHANGELOG.rst )
+
+distutils_enable_sphinx doc/sphinx/source --no-autodoc
+distutils_enable_tests unittest