summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2020-03-15 19:02:14 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-03-25 13:17:03 +0200
commit055a7acc374d9dad584e7e5af9a44afa346cb60d (patch)
tree950fb81b4d46c77cb55644c65752b33be800f58c /dev-python/breathe/breathe-4.14.1.ebuild
parentdev-vcs/git-lfs: Add myself as a proxied maintainer (diff)
downloadgentoo-055a7acc374d9dad584e7e5af9a44afa346cb60d.tar.gz
gentoo-055a7acc374d9dad584e7e5af9a44afa346cb60d.tar.bz2
gentoo-055a7acc374d9dad584e7e5af9a44afa346cb60d.zip
dev-python/breathe: Bump version to v4.14.1
This is needed for building sys-cluster/hpx' documentation. Closes: https://bugs.gentoo.org/685006 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/breathe/breathe-4.14.1.ebuild')
-rw-r--r--dev-python/breathe/breathe-4.14.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/breathe/breathe-4.14.1.ebuild b/dev-python/breathe/breathe-4.14.1.ebuild
new file mode 100644
index 000000000000..d6aacc5d3045
--- /dev/null
+++ b/dev-python/breathe/breathe-4.14.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx Doxygen renderer"
+HOMEPAGE="https://breathe.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-doc/doxygen
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+"