summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-06-13 18:15:34 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-06-13 18:15:50 +0000
commitc63709a3998d208aae5ec3673417ee8fd1f70623 (patch)
tree06d738c95d250b79cfbc8676c053f15221ee71db /dev-python/brython/brython-3.2.6.ebuild
parentdev-db/percona-server: Version bump to 5.6.30.76.3 wrt bug 584882 (diff)
downloadgentoo-c63709a3998d208aae5ec3673417ee8fd1f70623.tar.gz
gentoo-c63709a3998d208aae5ec3673417ee8fd1f70623.tar.bz2
gentoo-c63709a3998d208aae5ec3673417ee8fd1f70623.zip
dev-python/brython: Add Brython to the tree.
Brython is a JavaScript library but also a Python 3 implementation for client-side web programming. It allows developers to write Python code in and for the browser instead of JavaScript code. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/brython/brython-3.2.6.ebuild')
-rw-r--r--dev-python/brython/brython-3.2.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/brython/brython-3.2.6.ebuild b/dev-python/brython/brython-3.2.6.ebuild
new file mode 100644
index 000000000000..feed5f4f8364
--- /dev/null
+++ b/dev-python/brython/brython-3.2.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit webapp
+
+DESCRIPTION="A Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="https://github.com/${PN}-dev/${PN}/archive/${PV}.zip -> ${P}.zip"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/python:*"
+
+DEPEND="${RDEPEND}"
+
+need_httpd_cgi
+
+src_install() {
+ dodoc LICENCE.txt README.md
+ rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}