summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-05-25 10:44:05 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-05-25 10:44:05 +0200
commitc168c3d3edd411ab78c522af552a5e452baecfd4 (patch)
treed68b0a4bea1609d9f3c117a43dfdf39154bf901d /dev-python/brython/brython-3.3.2.ebuild
parentnet-misc/tigervnc: version bump to 1.8.0. (diff)
downloadgentoo-c168c3d3edd411ab78c522af552a5e452baecfd4.tar.gz
gentoo-c168c3d3edd411ab78c522af552a5e452baecfd4.tar.bz2
gentoo-c168c3d3edd411ab78c522af552a5e452baecfd4.zip
dev-python/brython: version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/brython/brython-3.3.2.ebuild')
-rw-r--r--dev-python/brython/brython-3.3.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/brython/brython-3.3.2.ebuild b/dev-python/brython/brython-3.3.2.ebuild
new file mode 100644
index 000000000000..230fd50c5231
--- /dev/null
+++ b/dev-python/brython/brython-3.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+DESCRIPTION="A Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="https://github.com/${PN}-dev/${PN}/archive/${PV}.zip -> ${P}.zip"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-lang/python:*"
+DEPEND="${RDEPEND}"
+
+need_httpd_cgi
+
+src_install() {
+ dodoc LICENCE.txt README.md
+ rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}