summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-05-28 23:14:23 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-06-01 23:55:46 +0200
commit3192f5186fce9a575933fa5c63b230ede906f667 (patch)
treeb29c9f92ed870cf79e8e55629e742f6e9938249c /dev-python/brython/brython-3.7.2.ebuild
parentapp-misc/i2bits: clean up old. (diff)
downloadgentoo-3192f5186fce9a575933fa5c63b230ede906f667.tar.gz
gentoo-3192f5186fce9a575933fa5c63b230ede906f667.tar.bz2
gentoo-3192f5186fce9a575933fa5c63b230ede906f667.zip
dev-python/brython: version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python/brython/brython-3.7.2.ebuild')
-rw-r--r--dev-python/brython/brython-3.7.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/brython/brython-3.7.2.ebuild b/dev-python/brython/brython-3.7.2.ebuild
new file mode 100644
index 000000000000..447c9b9ba91f
--- /dev/null
+++ b/dev-python/brython/brython-3.7.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit webapp python-single-r1
+
+DESCRIPTION="A Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="https://github.com/${PN}-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ dodoc LICENCE.txt README.md
+ rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}