summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-02-01 23:24:08 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-02-02 00:06:40 +0100
commitd31db15d167148c06e333882b8f6958f62f1be5c (patch)
tree1b7ecb39c299d124bcddbeb38896a58d6df9a882 /dev-python/brython
parentdev-db/etcd: Remove old (diff)
downloadgentoo-d31db15d167148c06e333882b8f6958f62f1be5c.tar.gz
gentoo-d31db15d167148c06e333882b8f6958f62f1be5c.tar.bz2
gentoo-d31db15d167148c06e333882b8f6958f62f1be5c.zip
dev-python/brython: version bump.
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python/brython')
-rw-r--r--dev-python/brython/Manifest1
-rw-r--r--dev-python/brython/brython-3.3.4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/brython/Manifest b/dev-python/brython/Manifest
index d0ae6ec1eaba..b4f5c9eedab4 100644
--- a/dev-python/brython/Manifest
+++ b/dev-python/brython/Manifest
@@ -1 +1,2 @@
DIST brython-3.3.3.zip 10040987 BLAKE2B a6a238ac6189e9170653c1987db46f2e0735f25deccaf0318ebc669b48dce1330acf333ef27300f1061e7e18044cfa24fadc02265d0fe3a83d0aa8b97f4de684 SHA512 e182a6c859cd18b90b205f751260b0b5c8d250746e48844c59cd61608dfdaf0fd6f0f25b8061de9505b7c5d094ac68fe57536c52cb31adb48f04c2cc5624e249
+DIST brython-3.3.4.zip 10047374 BLAKE2B ba4719476206fd71f412d646deb6a7eea3a0aef930814d7fa3589a3e736818f2bc7edf7f642998ae1471da87e3ad05ce89fd9dd32d569267ba45174543e4e520 SHA512 818181e040eefaeffd1e8866af471626ff5874fd99c3ee9fcc09c46a4b4b836619045a2712a8e16121a1132c86407b0676a8125e707eff4c7e867851cf20cecd
diff --git a/dev-python/brython/brython-3.3.4.ebuild b/dev-python/brython/brython-3.3.4.ebuild
new file mode 100644
index 000000000000..fe8fc801b10e
--- /dev/null
+++ b/dev-python/brython/brython-3.3.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit webapp python-single-r1
+
+DESCRIPTION="A Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="https://github.com/${PN}-dev/${PN}/archive/${PV}.zip -> ${P}.zip"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ dodoc LICENCE.txt README.md
+ rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}