summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-12 12:38:53 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-12 12:40:44 +0200
commitac3229869584915ae0af3030cbc3802e63720c9b (patch)
treecaaccd5e85a29fad32ab30cf519c5e7c50cde45c /dev-python/build
parentdev-python/pytest-rerunfailures: Enable py3.11 (diff)
downloadgentoo-ac3229869584915ae0af3030cbc3802e63720c9b.tar.gz
gentoo-ac3229869584915ae0af3030cbc3802e63720c9b.tar.bz2
gentoo-ac3229869584915ae0af3030cbc3802e63720c9b.zip
dev-python/build: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/build')
-rw-r--r--dev-python/build/build-0.7.0-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/build/build-0.7.0-r1.ebuild b/dev-python/build/build-0.7.0-r1.ebuild
index 1e9284e7e37e..049661a8726c 100644
--- a/dev-python/build/build-0.7.0-r1.ebuild
+++ b/dev-python/build/build-0.7.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1 multiprocessing
@@ -55,7 +55,11 @@ python_test() {
'tests/test_util.py::test_wheel_metadata[True]'
tests/test_util.py::test_with_get_requires
)
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # fixed in git but the patch is large-ish
+ tests/test_env.py::test_executable_missing_post_creation
+ )
- epytest -p no:flaky \
- -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+ epytest -p no:flaky -n "$(makeopts_jobs)" \
+ -W"ignore:path is deprecated.:DeprecationWarning"
}