summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2021-02-24 18:41:21 +1100
committerMichael Palimaka <kensington@gentoo.org>2021-02-24 18:41:21 +1100
commit3649afa1c2740f673a1155c46d766a1d98871671 (patch)
treeacda4970b4643df67e74890140ae102f27a64c22 /dev-python/cachelib/cachelib-0.1.1.ebuild
parentdev-python/keep: version bump 2.10.1 (diff)
downloadgentoo-3649afa1c2740f673a1155c46d766a1d98871671.tar.gz
gentoo-3649afa1c2740f673a1155c46d766a1d98871671.tar.bz2
gentoo-3649afa1c2740f673a1155c46d766a1d98871671.zip
dev-python/cachelib: version bump 0.1.1
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'dev-python/cachelib/cachelib-0.1.1.ebuild')
-rw-r--r--dev-python/cachelib/cachelib-0.1.1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/cachelib/cachelib-0.1.1.ebuild b/dev-python/cachelib/cachelib-0.1.1.ebuild
new file mode 100644
index 000000000000..1c7f69afd453
--- /dev/null
+++ b/dev-python/cachelib/cachelib-0.1.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of cache libraries in the same API interface. Extracted from werkzeug"
+HOMEPAGE="https://pypi.org/project/cachelib/ https://github.com/pallets/cachelib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"