summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-01-30 12:36:40 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-01-30 12:37:54 -0600
commit4c8cfe0f28c592ee5b1e1b169764c80cce87f237 (patch)
tree92c87b1c138c391155f81cb9d6723cb3d5380b05 /dev-python/cachetools/cachetools-3.1.0.ebuild
parentgnome-extra/gtlhtml: changed wrong keyword to ~x86 (diff)
downloadgentoo-4c8cfe0f28c592ee5b1e1b169764c80cce87f237.tar.gz
gentoo-4c8cfe0f28c592ee5b1e1b169764c80cce87f237.tar.bz2
gentoo-4c8cfe0f28c592ee5b1e1b169764c80cce87f237.zip
dev-python/cachetools: 3.1.0 bup
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/cachetools/cachetools-3.1.0.ebuild')
-rw-r--r--dev-python/cachetools/cachetools-3.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/cachetools/cachetools-3.1.0.ebuild b/dev-python/cachetools/cachetools-3.1.0.ebuild
new file mode 100644
index 000000000000..1c9f5b206796
--- /dev/null
+++ b/dev-python/cachetools/cachetools-3.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Extensible memoizing collections and decorators"
+HOMEPAGE="https://pypi.org/project/cachetools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}