summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-23 07:56:41 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-23 08:34:27 +0100
commitaecefad096659ade29fc6dc92422a47cc69e879c (patch)
treec84aecb2030692f89208acede12f36ad5e20da98 /dev-python/cachetools/cachetools-5.3.0.ebuild
parentdev-python/hypothesis: Bump to 6.64.0 (diff)
downloadgentoo-aecefad096659ade29fc6dc92422a47cc69e879c.tar.gz
gentoo-aecefad096659ade29fc6dc92422a47cc69e879c.tar.bz2
gentoo-aecefad096659ade29fc6dc92422a47cc69e879c.zip
dev-python/cachetools: Bump to 5.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cachetools/cachetools-5.3.0.ebuild')
-rw-r--r--dev-python/cachetools/cachetools-5.3.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/cachetools/cachetools-5.3.0.ebuild b/dev-python/cachetools/cachetools-5.3.0.ebuild
new file mode 100644
index 000000000000..b2389ae9952f
--- /dev/null
+++ b/dev-python/cachetools/cachetools-5.3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Extensible memoizing collections and decorators"
+HOMEPAGE="
+ https://github.com/tkem/cachetools/
+ https://pypi.org/project/cachetools/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests pytest