summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-06 19:48:36 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-06 20:00:06 +0300
commita16e682fa00d316b93114165cd6f41dc74aa50c6 (patch)
treef05fae8dff6f732e5cd79b0694fdf44a61521105 /dev-python/caldav
parentdev-python/curtsies: add 0.4.1 (diff)
downloadgentoo-a16e682fa00d316b93114165cd6f41dc74aa50c6.tar.gz
gentoo-a16e682fa00d316b93114165cd6f41dc74aa50c6.tar.bz2
gentoo-a16e682fa00d316b93114165cd6f41dc74aa50c6.zip
dev-python/caldav: add 0.9.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/caldav')
-rw-r--r--dev-python/caldav/Manifest1
-rw-r--r--dev-python/caldav/caldav-0.9.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/caldav/Manifest b/dev-python/caldav/Manifest
index 60290559a8fe..c9fcc11e5abf 100644
--- a/dev-python/caldav/Manifest
+++ b/dev-python/caldav/Manifest
@@ -1 +1,2 @@
DIST caldav-0.9.1.gh.tar.gz 105578 BLAKE2B 3581bb0f40daf312b32ff2ef88a31502449e0727f8e6178574c5350fb0312726d62cc9e4be3b9e73b4ee55282a32fcc503da48d49c3e7f0639a96de8197e6f8b SHA512 9171a09aa81bd6ad885aaaa3dac4cb53cb05235b37aa5be72d641b1cd2ee27928213eb95358654e99adfdbf70bea4567977509f972f54b8747162e91c95e1397
+DIST caldav-0.9.2.gh.tar.gz 109877 BLAKE2B a5a4a2b4a75bafbed11e91bab6e8de14863a9a9acea2ac87ac9bb3bb2b4f2bb509bb3e898b6d276af50e2863c97b1686b9dc51a3a641345501a1295b77464791 SHA512 6e325d49d8560220bf6e7c001c7ea11b0a24c0059954be6780db0a3938c48a4931b7615f576f09a8817c618c3881ada9f4a21bf2bd441326010a98066de520d6
diff --git a/dev-python/caldav/caldav-0.9.2.ebuild b/dev-python/caldav/caldav-0.9.2.ebuild
new file mode 100644
index 000000000000..a8da6ea96540
--- /dev/null
+++ b/dev-python/caldav/caldav-0.9.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="CalDAV (RFC4791) client library for Python"
+HOMEPAGE="
+ https://github.com/python-caldav/caldav
+ https://pypi.org/project/caldav/
+"
+SRC_URI="
+ https://github.com/python-caldav/caldav/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( GPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]
+"
+# For now, really does use nose imports: bug #857738
+BDEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ www-apps/radicale[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest