summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-25 16:06:25 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-25 16:06:25 -0500
commitd649a54a1b2db66ba2937ef6bafe47db610d78b9 (patch)
treefcff85e074fae3df309b426cbeb85d7ec67fe258 /dev-python/castellan/castellan-0.4.0.ebuild
parentkde-misc/skanlite: Version bump 2.0 (diff)
downloadgentoo-d649a54a1b2db66ba2937ef6bafe47db610d78b9.tar.gz
gentoo-d649a54a1b2db66ba2937ef6bafe47db610d78b9.tar.bz2
gentoo-d649a54a1b2db66ba2937ef6bafe47db610d78b9.zip
dev-python/castellan: bup for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/castellan/castellan-0.4.0.ebuild')
-rw-r--r--dev-python/castellan/castellan-0.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/castellan/castellan-0.4.0.ebuild b/dev-python/castellan/castellan-0.4.0.ebuild
new file mode 100644
index 000000000000..78a246205540
--- /dev/null
+++ b/dev-python/castellan/castellan-0.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic Key Manager interface for OpenStack"
+HOMEPAGE="https://pypi.python.org/pypi/castellan"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=" >=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3
+ >=dev-python/cryptography-1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-policy-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.5.0[${PYTHON_USEDEP}]"