summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 23:17:04 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 00:07:59 -0500
commit89a0c1e6967f3fd6ef5a736bd06e84d6316ac6f7 (patch)
tree0395af720a0632476bffe6f152a8abbd81f84c27 /dev-python/castellan/castellan-1.2.2.ebuild
parentdev-python/python-barbicanclient: add py37 support (diff)
downloadgentoo-89a0c1e6967f3fd6ef5a736bd06e84d6316ac6f7.tar.gz
gentoo-89a0c1e6967f3fd6ef5a736bd06e84d6316ac6f7.tar.bz2
gentoo-89a0c1e6967f3fd6ef5a736bd06e84d6316ac6f7.zip
dev-python/castellan: 1.2.2 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/castellan/castellan-1.2.2.ebuild')
-rw-r--r--dev-python/castellan/castellan-1.2.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/castellan/castellan-1.2.2.ebuild b/dev-python/castellan/castellan-1.2.2.ebuild
new file mode 100644
index 000000000000..ed896641438c
--- /dev/null
+++ b/dev-python/castellan/castellan-1.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic Key Manager interface for OpenStack"
+HOMEPAGE="https://pypi.org/project/castellan/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ >=dev-python/python-barbicanclient-4.5.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-6.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.19.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+"