summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-14 11:30:09 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-14 11:45:54 -0600
commitdacd9fb51d698b0717648914cfc8cb249c8e4e94 (patch)
treee5352e9596c97973a76b716c48abae8840b43853 /dev-python/casttube/casttube-0.2.0.ebuild
parentdev-python/zeroconf: 0.24.4 bump for py3 pulseaudio-dlna (diff)
downloadgentoo-dacd9fb51d698b0717648914cfc8cb249c8e4e94.tar.gz
gentoo-dacd9fb51d698b0717648914cfc8cb249c8e4e94.tar.bz2
gentoo-dacd9fb51d698b0717648914cfc8cb249c8e4e94.zip
dev-python/casttube: add for pychromecast
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/casttube/casttube-0.2.0.ebuild')
-rw-r--r--dev-python/casttube/casttube-0.2.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/casttube/casttube-0.2.0.ebuild b/dev-python/casttube/casttube-0.2.0.ebuild
new file mode 100644
index 000000000000..6d11275e5628
--- /dev/null
+++ b/dev-python/casttube/casttube-0.2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="casttube provides a way to interact with the Youtube Chromecast api."
+HOMEPAGE="https://github.com/ur1katz/casttube"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND=""