summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-30 18:32:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-30 18:34:10 +0200
commitf229ae435d2df93533da5b84678b7a1e0dcaa1bf (patch)
tree4edeba5d7e6590472c9213d81661ce02bd347945 /dev-python/catkin_pkg/catkin_pkg-0.4.7.ebuild
parentdev-python/Coffin: maintainer needed (diff)
downloadgentoo-f229ae435d2df93533da5b84678b7a1e0dcaa1bf.tar.gz
gentoo-f229ae435d2df93533da5b84678b7a1e0dcaa1bf.tar.bz2
gentoo-f229ae435d2df93533da5b84678b7a1e0dcaa1bf.zip
dev-python/catkin_pkg: bump to 0.4.7
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-python/catkin_pkg/catkin_pkg-0.4.7.ebuild')
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.4.7.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.4.7.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.4.7.ebuild
new file mode 100644
index 000000000000..263dc13362e4
--- /dev/null
+++ b/dev-python/catkin_pkg/catkin_pkg-0.4.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the catkin package system"
+HOMEPAGE="http://wiki.ros.org/catkin_pkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+"
+RDEPEND="${RDEPEND}
+ !<dev-util/catkin-0.7.14"
+PATCHES=(
+ "${FILESDIR}/catkin_prefix2.patch"
+ "${FILESDIR}/argparse.patch"
+ "${FILESDIR}/ros_packages.patch"
+ "${FILESDIR}/infinite_loop3.patch"
+)
+
+python_test() {
+ nosetests -s --tests test || die
+}